pkgsrc/security/isakmpd/patches/patch-ae
martti 7e162e0138 This is a new version taken from OpenBSD just before their next release.
Exact list of changes is unknown (you might take a look at OpenBSD's
log entries at http://www.openbsd.org/cgi-bin/cvsweb/src/sbin/isakmpd/)
2001-10-22 05:51:25 +00:00

45 lines
1.4 KiB
Text

$NetBSD: patch-ae,v 1.2 2001/10/22 05:51:25 martti Exp $
--- sysdep/netbsd/Makefile.sysdep.orig Mon Aug 13 14:33:35 2001
+++ sysdep/netbsd/Makefile.sysdep Sat Oct 20 15:46:49 2001
@@ -36,26 +36,20 @@
LIBCRYPTO= /usr/lib/libcrypto.a
LIBSYSDEPDIR= ${.CURDIR}/sysdep/common/libsysdep
-LDADD+= ${LIBGMP} ${LIBSYSDEPDIR}/libsysdep.a -lipsec
-DPADD+= ${LIBGMP} ${LIBSYSDEPDIR}/libsysdep.a ${LIBIPSEC}
+LDADD+= ${LIBSYSDEPDIR}/libsysdep.a -lipsec
+DPADD+= ${LIBSYSDEPDIR}/libsysdep.a ${LIBIPSEC}
CFLAGS+= -DNO_RSA -DNO_IDEA -DNO_RC5 -DHAVE_GETNAMEINFO \
-DHAVE_GETIFADDRS \
-I${.CURDIR}/sysdep/common
-.if exists(/usr/pkg/include/openssl/rsa.h)
-CFLAGS+= -I/usr/pkg/include/openssl
-.elif exists(/usr/include/openssl/rsa.h)
-CFLAGS+= -I/usr/include -I/usr/include/openssl
-.endif
# mandatory for gmp
-CFLAGS+= -I/usr/pkg/include
-LDADD+= -L/usr/pkg/lib
+CFLAGS+= -I@BUILDLINK_DIR@/include -I@BUILDLINK_DIR@/include/openssl
+LDADD+= -L@BUILDLINK_DIR@/lib
IPSEC_SRCS= pf_key_v2.c
IPSEC_CFLAGS= -DUSE_PF_KEY_V2
USE_LIBCRYPTO= defined
-USE_GMP= defined
# This is a hack in order to make sure libsysdep is built before the
# linkstage of isakmpd. As a side effect the link is always done even if
@@ -73,8 +67,4 @@
beforedepend:
rm -f ssl
-.if exists(/usr/pkg/include/openssl/rsa.h)
- ln -sf /usr/pkg/include/openssl ssl
-.elif exists(/usr/include/openssl/rsa.h)
- ln -sf /usr/include/openssl ssl
-.endif
+ ln -sf @BUILDLINK_DIR@/include/openssl ssl