1399060cc7
Taisei (lit. Occident) is a free and open-source fangame of the Touhou series. Basically, it is a shoot 'em up game with lots of bullets (the genre is literally called bullet hell). It doesn't aim to rebuild a particular installment of the Touhou games, but is rather an original game set in the world of Touhou.
25 lines
940 B
Text
25 lines
940 B
Text
$NetBSD: patch-scripts_meson.build,v 1.1 2019/09/21 15:19:17 nia Exp $
|
|
|
|
Don't depend on git for version checking.
|
|
|
|
--- scripts/meson.build.orig 2019-04-27 08:01:35.000000000 +0000
|
|
+++ scripts/meson.build
|
|
@@ -16,17 +16,7 @@ common_taiseilib_defs = [
|
|
# Workaround for Meson bug: https://github.com/mesonbuild/meson/issues/4947
|
|
python_thunk = find_program(files('thunk.py'))
|
|
|
|
-version_script = files('version.py')
|
|
-version_command = [python_thunk, version_script, common_taiseilib_args]
|
|
-
|
|
-taisei_version_result = run_command(version_command, '{string}')
|
|
-assert(taisei_version_result.returncode() == 0, 'Version script failed')
|
|
-
|
|
-if taisei_version_result.stderr() != ''
|
|
- warning(taisei_version_result.stderr().strip())
|
|
-endif
|
|
-
|
|
-taisei_version_string = taisei_version_result.stdout().strip()
|
|
+taisei_version_string = '@PKGVERSION@'
|
|
|
|
preprocess_script = files('configure-file.py')
|
|
# generators are string supremacists apparently...
|