pkgsrc/math/R/patches/patch-ad
adam 20b4be037e Changes 2.10.0:
* Package help is now converted from Rd by the R-based converters
  that were first introduced in 2.9.0.
* HTML help is now generated dynamically using an HTTP server
  running in the R process and listening on the loopback interface.
* polygon(), pdf() and postscript() now have a parameter
  'fillOddEven' (default FALSE), which controls the mode used for
  polygon fills of self-intersecting shapes.
* New debugonce() function; further,
  getOption("deparse.max.lines") is now observed when debugging.
* plot() methods for "stepfun" and hence "ecdf" no longer plot
  points by default for n >= 1000.
* [g]sub(*, perl=TRUE) now also supports '\E' in order to *end*
  \U and \L case changes, thanks to a patch from Bill Dunlap.
* factor(), `levels<-`(), etc, now ensure that the resulting factor
  levels are unique (as was always the implied intention).  Factors
  with duplicated levels are still constructible by low-level means,
  but are now declared illegal.
* New print() (S3) method for class "function", also used for
  auto-printing.  Further, .Primitive functions now print and
  auto-print identically.
* The print() and toLatex() methods for class "sessionInfo" now
  show the locale in a nicer format and have arguments to
  suppress locale information.
* In addition to previously only round(), there are other 'Math'
  group (S3) methods for 'difftime', such as floor(), signif(), abs(), etc.
* For completeness, old.packages() and available.packages() allow
  'type' to be specified (you could always specify 'available'
  or 'contriburl').
* More...
2009-12-11 18:53:40 +00:00

20 lines
1,007 B
Text

$NetBSD: patch-ad,v 1.13 2009/12/11 18:53:40 adam Exp $
--- src/main/Makefile.in.orig 2009-10-14 04:05:03.000000000 +0200
+++ src/main/Makefile.in
@@ -97,13 +97,13 @@ EXTRA_STATIC_LIBS = \
$(R_ZLIBS) $(R_BZLIBS) $(R_PCRE) $(R_TRE) $(R_XDR) $(R_XZ) $(R_LIBINTL)
STATIC_LIBS = $(MAIN_LIBS) $(EXTRA_STATIC_LIBS)
-EXTRA_LIBS = $(BLAS_LIBS) $(FLIBS) $(R_XTRA_LIBS) @LIBINTL@ $(READLINE_LIBS) $(LIBS)
+EXTRA_LIBS = $(BLAS_LIBS) $(FLIBS) $(R_XTRA_LIBS) @LIBINTL@ $(READLINE_LIBS) $(LIBS) @LIBMULTITHREAD@
R_binary = R.bin
R_bin_OBJECTS = Rmain.o
@WANT_R_SHLIB_FALSE@R_bin_LDADD = libR.a $(EXTRA_LIBS)
## Linked against -lRblas becasue -lR is and otherwise ld complains.
-@WANT_R_SHLIB_TRUE@R_bin_LDADD = -L../../lib@R_ARCH@ -lR @BLAS_SHLIB_TRUE@-lRblas
+@WANT_R_SHLIB_TRUE@R_bin_LDADD = -L../../lib@R_ARCH@ ${COMPILER_RPATH_FLAG}$(Rexeclibdir) -lR @BLAS_SHLIB_TRUE@-lRblas
R_bin_DEPENDENCIES =@WANT_R_SHLIB_FALSE@ libR.a @USE_EXPORTFILES_TRUE@ $(top_builddir)/etc/R.exp
libR_la = libR$(DYLIB_EXT)