* Type Based Alias Analysis (TBAA) is now implemented and turned on by default in Clang. This allows substantially better load/store optimization in some cases. TBAA can be disabled by passing -fno-strict-aliasing. * This release has seen a continued focus on quality of debug information. LLVM now generates much higher fidelity debug information, particularly when debugging optimized code. * Inline assembly now supports multiple alternative constraints. * A new backend for the NVIDIA PTX virtual ISA (used to target its GPUs) is under rapid development. It is not generally useful in 2.9, but is making rapid progress.
19 lines
729 B
Text
19 lines
729 B
Text
$NetBSD: patch-ab,v 1.2 2011/04/07 09:26:33 adam Exp $
|
|
|
|
--- docs/Makefile.orig 2011-02-11 07:43:27.000000000 +0000
|
|
+++ docs/Makefile
|
|
@@ -53,13 +53,12 @@ endif
|
|
# 'make generated BUILD_FOR_WEBSITE=1'
|
|
generated:: $(generated_targets)
|
|
|
|
-install-html: $(PROJ_OBJ_DIR)/html.tar.gz
|
|
+install-html:
|
|
$(Echo) Installing HTML documentation
|
|
$(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html
|
|
$(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/img
|
|
$(Verb) $(DataInstall) $(HTML) $(DESTDIR)$(PROJ_docsdir)/html
|
|
$(Verb) $(DataInstall) $(IMAGES) $(DESTDIR)$(PROJ_docsdir)/html/img
|
|
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
|
|
|
$(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
|
$(Echo) Packaging HTML documentation
|