28 lines
901 B
Text
28 lines
901 B
Text
$NetBSD: patch-aa,v 1.2 2005/09/27 12:25:35 tonio Exp $
|
|
|
|
--- progs/Makefile.in.orig 2002-09-24 06:26:50.000000000 +0200
|
|
+++ progs/Makefile.in
|
|
@@ -12,12 +12,12 @@ include ../Makefile.defs # for CC, CFLAG
|
|
# into the guts of the lexical scanner in order to ferret out the
|
|
# token stream. Thus, it needs access to the PCCTS header files in
|
|
# order to compile.
|
|
-LIBDIR = ..
|
|
-CPPFLAGS = -I$(LIBDIR) -I$(LIBDIR)/pccts -I$(LIBDIR)/src
|
|
+LIBDIR = ${PREFIX}/lib
|
|
+CPPFLAGS = -I.. -I../pccts -I../src
|
|
|
|
LIBDIRS = -L$(LIBDIR) $(OTHERLIBDIRS)
|
|
LIBS = -lbtparse $(OTHERLIBS)
|
|
-LDFLAGS = $(LIBDIRS) $(LIBS)
|
|
+LDFLAGS = $(LIBDIRS) $(LIBS) -Wl,-R$(LIBDIR)
|
|
|
|
BPSRC = bibparse.c args.c @GETOPT_SRC@
|
|
BPOBJ = $(BPSRC:.c=.o)
|
|
@@ -46,7 +46,6 @@ dumpnames : $(DNOBJ) lib
|
|
$(CC) -o $@ $(CFLAGS) $(DNOBJ) $(LDFLAGS)
|
|
|
|
lib:
|
|
- cd $(LIBDIR) ; make lib
|
|
|
|
clean:
|
|
rm -f $(BPOBJ) $(BLOBJ) $(DNOBJ) $(BXOBJ) core logfile
|