461e015572
the Curses Development Kit
26 lines
871 B
Text
26 lines
871 B
Text
$NetBSD: patch-ah,v 1.1.1.1 1998/12/01 23:27:36 garbled Exp $
|
|
--- exam/Makefile.orig Tue Apr 7 09:25:04 1998
|
|
+++ exam/Makefile Tue Dec 1 16:12:44 1998
|
|
@@ -5,17 +5,17 @@
|
|
#
|
|
# Change these as needed.
|
|
#
|
|
-ROOTDIR = /export/local
|
|
-INCDIR = -I/usr/include/ncurses -I$(ROOTDIR)/include
|
|
-LIBDIR = -L$(ROOTDIR)/lib
|
|
-LIBS = -lcdk -lcurses -lm
|
|
+ROOTDIR = /usr/pkg
|
|
+INCDIR = -I$(ROOTDIR)/include
|
|
+LIBDIR = -Wl,-R$(ROOTDIR)/lib -L$(ROOTDIR)/lib
|
|
+LIBS = -lcdk -lncurses -lm
|
|
BINS = alphalist_ex bind_ex calendar_ex cdkscreen_ex dialog_ex\
|
|
entry_ex fselect_ex graph_ex hello_ex histogram_ex\
|
|
itemlist_ex label_ex marquee_ex matrix_ex mentry_ex\
|
|
menu_ex position_ex preprocess_ex radio_ex scale_ex\
|
|
scroll_ex selection_ex slider_ex subwindow_ex\
|
|
swindow_ex template_ex viewer_ex vinstall
|
|
-CFLAGS = -g -Wall
|
|
+CFLAGS = -O -DNCURSES
|
|
CC = gcc
|
|
default: all
|
|
all: $(BINS)
|