8f1f0ff6cc
* statistics/regress: new function * general bug fixes and improvements (see ChangeLog for details) * audio/waveread: big-endian fix; 2-channel file fix * comm/galois: fix rank calculation for galois array * general/interp2: cubic interpolation * image/: return MxNx3 matrices of appropriate numeric class * io/textread: faster * io/dlmwrite: control precision and line separator; allow append * miscellaneous/mfilename: compatibility function * miscellaneous/listen: subnet patterns; loopback support * NaN/xcovf: missing data xcorr * octcdf/: support for netcdf files * optim/wpolyfit: return row vector; allow centering and scaling * plot/legend: fix error on first call * plot/print: add PDF option * signal/residued,residuez: partial fraction expansion of filters * signal/qp_kaiser: PPN filter bank coefficients * statistics/histfit: allow negative data * statistics/mvnpdf,mvnrnd: multivariate normal distribution * tsa/: improved speed, style and docs * tsa/amarma: adaptive mean ARMA modeling * tsa/y2res: add entropy estimation; add equidistant quantisation * tsa/mvfreqz: add PDCF * support for 2.9.4 * support for 64-bit indexing * support for MinGW build
33 lines
891 B
Text
33 lines
891 B
Text
$NetBSD: patch-al,v 1.2 2006/04/20 18:16:47 adam Exp $
|
|
|
|
--- main/plot/Makefile.orig 2006-03-12 21:39:09.000000000 +0100
|
|
+++ main/plot/Makefile
|
|
@@ -11,6 +11,7 @@ ifndef OCTAVE_FORGE
|
|
X_LIBS = -L/usr/X11R6/lib
|
|
endif
|
|
|
|
+X_LIBS2= $(filter-out -R%, ${X_LIBS})
|
|
|
|
%.o: %.cc ; $(MKOCTFILE) -c $(X_CFLAGS) $<
|
|
|
|
@@ -24,16 +25,16 @@ endif
|
|
$(PROGS:.oct=.o): graphics.h
|
|
|
|
grab.oct: grab.o graphics.o
|
|
- $(MKOCTFILE) $< graphics.o $(X_LIBS) -o $@
|
|
+ $(MKOCTFILE) $< graphics.o $(X_LIBS2) -o $@
|
|
|
|
gpick.oct: gpick.o graphics.o
|
|
- $(MKOCTFILE) $< graphics.o $(X_LIBS) -o $@
|
|
+ $(MKOCTFILE) $< graphics.o $(X_LIBS2) -o $@
|
|
|
|
gtext.oct: gtext.o graphics.o
|
|
- $(MKOCTFILE) $< graphics.o $(X_LIBS) -o $@
|
|
+ $(MKOCTFILE) $< graphics.o $(X_LIBS2) -o $@
|
|
|
|
gzoom.oct: gzoom.o graphics.o
|
|
- $(MKOCTFILE) $< graphics.o $(X_LIBS) -o $@
|
|
+ $(MKOCTFILE) $< graphics.o $(X_LIBS2) -o $@
|
|
|
|
%.m : %.m.in
|
|
-$(INSTALL) $< $@
|