3530f6ba5c
* Numerous bug fixes for most of the PAM modules, including several string length checks and fixes (update recommended!). * fix for legacy behavior of pam_setcred and pam_close_session in the case that pam_authenticate and pam_open_session hadn't been called * pam_unix: - don't zero out password strings during password changing function * pam_wheel: - feature: can use the module to provide wheel access to non-root accounts. * pam_limits: - added '%' domain for maxlogins limiting, now '*' and @group have the old meaning (every) and '%' the new one (all) - handle negative priority limits (which can apply to the superuser too). * pam_userdb: - require that all of typed password matches that in database * pam_access: - added the 'fieldsep=' argument, made a PAM_RHOST of "" equivalent to NULL Incidentally, cups-1.1.18 will once again do PAM authentication using pam_unix.so if built against PAM-0.77.
13 lines
531 B
Text
13 lines
531 B
Text
$NetBSD: patch-aj,v 1.3 2002/12/23 21:23:59 jlam Exp $
|
|
|
|
--- modules/pam_env/Makefile.orig Sun Nov 19 18:54:03 2000
|
|
+++ modules/pam_env/Makefile
|
|
@@ -15,8 +15,4 @@ INSTALLED_CONFILE=$(SCONFIGD)/pam_env.co
|
|
DEFS=-DDEFAULT_CONF_FILE=\"$(INSTALLED_CONFILE)\"
|
|
CFLAGS += $(DEFS)
|
|
|
|
-MODULE_SIMPLE_INSTALL=bash -f ../install_conf "$(FAKEROOT)" "$(SCONFIGD)" "$(INSTALLED_CONFILE)" "$(TITLE)" "$(LOCAL_CONFILE)"
|
|
-MODULE_SIMPLE_REMOVE=rm -f $(FAKEROOT)$(INSTALLED_CONFILE)
|
|
-MODULE_SIMPLE_CLEAN=rm -f ./.ignore_age
|
|
-
|
|
include ../Simple.Rules
|