pkgsrc/mail/courier-mta/patches/patch-ax
adam 2e85bc7502 Changes 0.68.1:
* rfc2045mkboundary.c was broken in 0.68

Changes 0.68:
* rfc2045/rfc2045mkboundary.c (rfc2045_mk_boundary): truncate
the hostname portion of the boundary to 30 chars.
* courier/doc/courier.sgml: Remove descriptions of some configuration
files that were moved to the courier-authlib package a while ago.
They don't belong here any more.
* courier/submit.C: Use the authenticated address, instead of the
return address, for domain-based virtual configuration.
* courier/libs/cfilename.c (config_has_vhost): Checks whether
vhost.[ip] exists.
* courier/module.esmtp/courieresmtpd.c (main): Only set a message's
virtual host if vhost.[ip] exists.
* courier/module.esmtp/esmtpclient.c (get_sourceaddr): Make sure the
input buffer is null-terminated.
* courier/submit.C (getrcpts): If there's no vhost setting from the
sender's IP address (this includes local mail!) if vhost.domain exists,
use [domain] as the virtual host.
* Remove config_search(), which simply called config_localfilename().
Change all current callers to call config_localfilename().
* courier/libs/cfilename.c (config_set_local_vhost): saves a string
that gets appended as a suffix, by config_localfilename(), and if that
filename exists, that's returned as the filename, otherwise it's the
original string without the suffix. config_get_local_vhost() returns
the suffix string.
to config_set_local_vhost().
* courier/libs/comsubmitclient.c (submit_fork): If
config_get_local_vhost(), add a -vhost parameter to submit().
* courier/submit.C (cppmain): -vhost sets config_set_local_vhost().
* courier/submit2.C (closectl): New COMCTLFILE_VHOST parameter in the
config file, taken from the vhost setting.
* courier/libs/comctlfile.c (ctlfile_setvhost): If COMCTLFILE_VHOST is
set, call ctlfile_setvhost(), return an indication if the vhost has
changed. Absence of a COMCTLFILE_VHOST treated as a discrete "(null)"
setting.
* courier/module.esmtp/esmtpclient.c (esmtpchild): If ctlfile_setvhost()
then disconnect the current socket, if one is open.
* courier/module.esmtp/esmtpclient.c (get_sourceaddr): The IP address
specified in ipout or ip6out overrides SOURCE_ADDRESS and
SOURCE_ADDRESS_IPV6 environment variable.
* courier/module.local/localmail.c (main): Call ctlfile_setvhost().
* courier/module.uucp/uucp.c (uux): Call ctlfile_setvhost().
* courier/module.dsn/dsn.c (main): Call ctlfile_setvhost().
* liblock/mail.c (dotlock_exists): Quell a compiler warning.
* courier/courierd.dist.in SOURCE_ADDRESS: Add a note that this setting
is deprecated.
2012-06-09 11:45:38 +00:00

22 lines
1.3 KiB
Text

$NetBSD: patch-ax,v 1.3 2012/06/09 11:45:38 adam Exp $
--- courier/module.esmtp/Makefile.in.orig 2007-11-17 19:49:38.000000000 -0500
+++ courier/module.esmtp/Makefile.in
@@ -954,17 +954,11 @@ install-data-local:
test -f $(DESTDIR)$(sbindir)/courieresmtpd && exit 0; $(mkinstalldirs) $(DESTDIR)$(sbindir) || :; rm -f $(DESTDIR)$(sbindir)/courieresmtpd && $(LN_S) $(moduledir)/courieresmtpd $(DESTDIR)$(sbindir)/courieresmtpd
-$(mkinstalldirs) $(DESTDIR)$(bindir)
test -f $(DESTDIR)$(bindir)/addcr && exit 0; rm -f $(DESTDIR)$(bindir)/addcr && $(LN_S) $(moduledir)/addcr $(DESTDIR)$(bindir)/addcr
- -$(mkinstalldirs) $(DESTDIR)$(sysconfdir)/esmtpacceptmailfor.dir
- -$(mkinstalldirs) $(DESTDIR)$(sysconfdir)/esmtppercentrelay.dir
-$(mkinstalldirs) $(DESTDIR)$(sbindir)
for f in $(databin_SCRIPTS) ; do \
rm -f $(DESTDIR)$(sbindir)/$$f ; \
$(LN_S) $(datadir)/$$f $(DESTDIR)$(sbindir)/$$f ; done
cat </dev/null >>$(DESTDIR)$(sysconfdir)/esmtpauthclient
- chmod 600 $(DESTDIR)$(sysconfdir)/esmtpauthclient
- test -w /etc || exit 0; \
- chown @mailuser@ $(DESTDIR)$(sysconfdir)/esmtpauthclient ; \
- chgrp @mailgroup@ $(DESTDIR)$(sysconfdir)/esmtpauthclient
rm -f $(DESTDIR)$(sbindir)/esmtpd-msa $(DESTDIR)$(sbindir)/makesmtpaccess-msa
$(LN_S) esmtpd $(DESTDIR)$(sbindir)/esmtpd-msa
$(LN_S) makesmtpaccess $(DESTDIR)$(sbindir)/makesmtpaccess-msa