6b9136eb08
- move options to options.mk file and reorganize a bit - sort PLIST - grab MAINTAINERship ok by xtraeme. ChangeLog for pearpc-0.4: - CPU: stfiwx implemented - config: "ppc_start_fullscreen" for starting in fullscreen mode - POSIX: allow bridging of tun device - use FISTTP instruction on SSE3 aware processors - merged native_cd branch from Alexander Stockinger - endianess fixes - warn that the generic CPU is slow - better detection of HFS+ volumes - support for DVD-Drives - correctly check for NASM - Work-around for graphic errors in Mac OS X 10.1 - POSIX/Linux: fall back to 1 GHz if /proc/cpuinfo doesn't provide cpu frequency - 3c90x emulation fixed - some PROM fixed for yaboot - alteration of x86asm interface to be more programmer friendly - use transparent cursors instead of altering cursor visibility (hack for using PearPC with remote desktop) - DVD emulation implemented. Fixes problems with Tiger installation - Updated the read_effective_* commands to be faster !!! REGRESSED !!! - fixed lvalue casts (compiles now with gcc 4.x) - booting from disks with bootfile about 4 GiB limit fixed
28 lines
1 KiB
Text
28 lines
1 KiB
Text
$NetBSD: patch-aa,v 1.2 2005/12/22 19:27:36 ghen Exp $
|
|
|
|
--- src/system/osapi/posix/systimer.cc.orig 2005-12-21 14:43:21.000000000 +0100
|
|
+++ src/system/osapi/posix/systimer.cc
|
|
@@ -31,7 +31,11 @@
|
|
static const int kTimerSignal = SYSTIMER_SIGNAL;
|
|
#ifdef USE_POSIX_REALTIME_CLOCK
|
|
static void signal_handler(int signo, siginfo_t *extra, void *junk);
|
|
+# ifdef __NetBSD__
|
|
+static const int kClockRT = CLOCK_PROF;
|
|
+# else
|
|
static const int kClockRT = CLOCK_PROCESS_CPUTIME_ID;
|
|
+# endif
|
|
static const int kClock = CLOCK_REALTIME;
|
|
#elif USE_POSIX_SETITIMER
|
|
static void signal_handler(int signo);
|
|
@@ -70,7 +74,11 @@ struct sys_timer_struct
|
|
#ifdef USE_POSIX_REALTIME_CLOCK
|
|
static void signal_handler(int signo, siginfo_t *extra, void *junk)
|
|
{
|
|
+# ifndef __NetBSD__
|
|
sys_timer_struct *timer = reinterpret_cast<sys_timer_struct *>(extra->si_value.sival_ptr);
|
|
+# else
|
|
+ sys_timer_struct *timer = reinterpret_cast<sys_timer_struct *>(extra->si_sigval.sival_ptr);
|
|
+# endif
|
|
timer->callback(reinterpret_cast<sys_timer>(timer));
|
|
}
|
|
#else
|