bd416fcbfe
- Rewrite player to use libxmp 4.0 - Give Pulseaudio higher priority than ALSA - Give ALSA output higher priority than OSS - Fix native-endian coreaudio output - Fix module-specifc flags to override built-in quirks - Fix loop when skipping to first file and it's not playable - Add commands '<' and '>' to jump to previous/next sequence - Add command 'z' to toggle the subsong explorer on/off - Add option -z <num> to play a specified sequence - Add option -Z to play all sequences in module - Add option --loop-all to loop over entire module list
28 lines
1.2 KiB
Text
28 lines
1.2 KiB
Text
$NetBSD: patch-etc_Makefile,v 1.2 2013/11/16 07:41:02 shattered Exp $
|
|
|
|
--- src/Makefile.in.orig 2013-05-19 14:44:09.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -509,18 +509,18 @@ uninstall-man1:
|
|
dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
|
|
install-pkgsysconfDATA: $(pkgsysconf_DATA)
|
|
@$(NORMAL_INSTALL)
|
|
- @list='$(pkgsysconf_DATA)'; test -n "$(pkgsysconfdir)" || list=; \
|
|
+ @list='$(pkgsysconf_DATA)'; test -n "$(datarootdir)/examples/xmp" || list=; \
|
|
if test -n "$$list"; then \
|
|
- echo " $(MKDIR_P) '$(DESTDIR)$(pkgsysconfdir)'"; \
|
|
- $(MKDIR_P) "$(DESTDIR)$(pkgsysconfdir)" || exit 1; \
|
|
+ echo " $(MKDIR_P) '$(DESTDIR)$(datarootdir)/examples/xmp/'"; \
|
|
+ $(MKDIR_P) "$(DESTDIR)$(datarootdir)/examples/xmp/" || exit 1; \
|
|
fi; \
|
|
for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
echo "$$d$$p"; \
|
|
done | $(am__base_list) | \
|
|
while read files; do \
|
|
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgsysconfdir)'"; \
|
|
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgsysconfdir)" || exit $$?; \
|
|
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(datarootdir)/examples/xmp/'"; \
|
|
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(datarootdir)/examples/xmp/" || exit $$?; \
|
|
done
|
|
|
|
uninstall-pkgsysconfDATA:
|