pkgsrc/x11/xscreensaver/patches/patch-ad
wiz d5933401a8 Update xscreensaver to 4.18:
4.18                              14-Aug-2004
   * Oops, pay no attention to the man behind the curtain.
 4.17                              14-Aug-2004
   * New hacks, anemotaxis and memscroller.
   * Fixed a bad bug that caused vidwhacker to never die.
   * Fixed normals and lighting in polyhedra.
   * Don't reuse the window when changing hacks (to work around bugs in some GL
     implementations.)
   * Made xscreensaver-getimage-file skip thumbnail-sized images.
   * Fixed endian problem in barcode on non-x86.
   * Updates to webcollage, apple2, fuzzyflakes, atunnel, and pacman.
   * Timing tweaks to bubble3d, bouncingcow, engine, gltext, lavalite,
     molecule, spotlight, sballs, boxed, blinkbox, and circuit.
   * Configure updates for Fedora core 2 / xorg 6.7.0.
   * Compile without warnings under gcc 3.3.3.
   * I give up: don't blank or lock the screen if we can't get a keyboard grab.
     In that case, both choices are bad.
2004-09-27 14:19:44 +00:00

68 lines
4.2 KiB
Text

$NetBSD: patch-ad,v 1.13 2004/09/27 14:19:44 wiz Exp $
--- driver/Makefile.in.orig 2004-08-15 00:22:38.000000000 +0200
+++ driver/Makefile.in
@@ -292,7 +292,7 @@ install-program: $(EXES)
fi ; \
echo $$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver ; \
$$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver
- @for exe in xscreensaver-command xscreensaver-demo \
+ @for exe in xscreensaver-command \
xscreensaver-getimage @EXES_OSX@ ; do \
echo $(INSTALL_PROGRAM) $$exe $(install_prefix)$(bindir)/$$exe ; \
$(INSTALL_PROGRAM) $$exe $(install_prefix)$(bindir)/$$exe ; \
@@ -467,7 +467,7 @@ install-pam:
fi ; \
fi
-install-gnome:: screensaver-properties.desktop
+xxxinstall-gnome:: screensaver-properties.desktop
@lost="" ;\
if [ "$(GNOME_DATADIR)" != "" ]; then \
\
@@ -475,10 +475,6 @@ install-gnome:: screensaver-properties.d
echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_1)" ;\
$(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_1)" ;\
fi ;\
- if [ ! -d "$(install_prefix)$(GNOME_CCDIR_2)" ]; then \
- echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_2)" ;\
- $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_2)" ;\
- fi ;\
if [ ! -d "$(install_prefix)$(GNOME_CCDIR_3)" ]; then \
echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_3)" ;\
$(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_3)" ;\
@@ -499,16 +495,6 @@ install-gnome:: screensaver-properties.d
fi ;\
\
echo $(INSTALL_DATA) screensaver-properties.desktop \
- $(install_prefix)$(GNOME_CCDIR_2)/screensaver-properties.desktop;\
- \
- if $(INSTALL_DATA) screensaver-properties.desktop \
- $(install_prefix)$(GNOME_CCDIR_2)/screensaver-properties.desktop;\
- then true ;\
- else \
- lost="$$lost $(install_prefix)$(GNOME_CCDIR_2)" ;\
- fi ;\
- \
- echo $(INSTALL_DATA) screensaver-properties.desktop \
$(install_prefix)$(GNOME_CCDIR_3)/screensaver-properties.desktop;\
\
if $(INSTALL_DATA) screensaver-properties.desktop \
@@ -542,7 +528,7 @@ install-gnome:: screensaver-properties.d
fi ;\
fi
-install-gnome:: screensaver-properties-capplet
+xxxinstall-gnome:: screensaver-properties-capplet
@if [ "$(GNOME_DATADIR)" != "" ]; then \
if [ ! -d "$(install_prefix)$(GNOME_BINDIR)" ]; then \
echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_BINDIR)" ;\
@@ -641,8 +627,6 @@ uninstall-gnome::
f=screensaver-properties.desktop ;\
echo rm -f $(install_prefix)$(GNOME_CCDIR_1)/$$f ;\
rm -f $(install_prefix)$(GNOME_CCDIR_1)/$$f ;\
- echo rm -f $(install_prefix)$(GNOME_CCDIR_2)/$$f ;\
- rm -f $(install_prefix)$(GNOME_CCDIR_2)/$$f ;\
echo rm -f $(install_prefix)$(GNOME_CCDIR_3)/$$f ;\
rm -f $(install_prefix)$(GNOME_CCDIR_3)/$$f ;\
echo rm -f $(install_prefix)$(GNOME_PANELDIR)/$$f ;\