pkgsrc/net/ucd-snmp/patches/patch-ad
kim d5d93d218a Update to 4.1.2:
*4.1.2*
 Fixes:
    - Host resources fixes for FreeBSD and NetBSD
    - ucd-snmp memory/vmstat fixes for FreeBSD-3
    - configure --enable-ipv6 fixes
    - AIX fix (use knlist)
    - fix init_master_agent calling exit
    - bad free in subagent.c
    - dont let a agentx subagent be a smux master
    - ucd-snmp/loadave fix for AIX
    - fix doing a set on a pass variable
    - snmptable fixes
    - snmpnetstat fixes for v2c exceptions
    - man page fixes

 Features:
    - Some UnixWare 5 configuration support
    - configure --enable-mini-agent --without-openssl
    - snmptrapd -n
    - snmp_log callbacks
    - noTokenWarnings and noRangeCheck in snmp.conf
    - using a counter type in snmpset/snmptrap

*4.1.1*
 Fixes:
    - Better agent handling of unauthorized requests.
    - Better "make test" support.
    - Misc bug fixes.

*4.1*
 New:
    - Many new command line flags have been added for input/output flexibility.
      (see the snmpcmd(1) manual page on the -O flag and -I flag)
    - The tools support regex matching of oids on the command line.
      (see the snmpcmd(1) manual page on the -Ib option)
    - A ucd-snmp usage tutorial has been placed on the main web page.
      (see http://ucd-snmp.ucdavis.edu/tutorial)
    - snmptable is much smarter and handles sparse tables better.
    - tkmib supports snmpv3.
    - New agent libraries to embed SNMP and AgentX agents into other programs.
      (see the snmp_agent_api(3) manual page and the tutorial)
    - SNMP over TCP is supported.
      (-T TCP on the command lines)
    - OpenSSL has replaced KMT for SHA authentication and DES encryption.
      (Get OpenSSL from http://www.openssl.org/).
    - Some easier-to-use access-control snmpd.conf directives for simple setups.
      (see the snmpd.conf(5) manual page)
    - Easier setup of SNMPv3 support for the agent.
      (see the README.snmpv3 file).
    - Command line argument parsing has been reworked for getopt() use.
      (currently backwards compatible; see the snmpcmd(1) manual page)
    - Table rows with embedded strings are dealt with for both input and output.
      (see the snmpcmd(1) manual on the -Ob flag)
    - Many more snmp.conf directives supported.
      (see the snmp.conf(5) manual page)
    - Many AgentX improvements.
    - All of our distributed mibs have been updated to be SMIv2 compliant.
    - Trap support in the agent has been cleaned up and an API created.

 Perl:
    - Joe Marzot's perl module is now included with the ucd-snmp source.
      (this should help people trying to synchronize the two packages)

 Fixes:
    - SMUX support has been reintegrated into the agent in a better way.
    - Many many others.
2000-10-13 17:55:35 +00:00

86 lines
4.2 KiB
Text

$NetBSD: patch-ad,v 1.4 2000/10/13 17:55:36 kim Exp $
--- apps/Makefile.in.orig Tue Apr 18 06:46:55 2000
+++ apps/Makefile.in Wed Oct 11 19:04:29 2000
@@ -14,5 +14,7 @@
-USELIBS = ../snmplib/libsnmp.$(SHLIB_EXTENSION)$(SHLIB_VERSION)
-LOCAL_LIBS = -L../snmplib
-LIBS = $(CC_RUNTIME_ARG) -lsnmp @LIBS@
+#USELIBS = ../snmplib/libsnmp.$(SHLIB_EXTENSION)$(SHLIB_VERSION)
+USELIBS= ../snmplib/libsnmp.la
+#LOCAL_LIBS = -L../snmplib
+#LIBS = $(CC_RUNTIME_ARG) -lsnmp @LIBS@
+LIBS= ${USELIBS} @LIBS@
@@ -33,33 +35,33 @@
snmpwalk: snmpwalk.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpwalk.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpwalk.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpbulkwalk: snmpbulkwalk.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpbulkwalk.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpbulkwalk.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpbulkget: snmpbulkget.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpbulkget.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpbulkget.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmptranslate: snmptranslate.o $(USELIBS)
- ${CC} -o $@ snmptranslate.o $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmptranslate.o $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpstatus: snmpstatus.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpstatus.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpstatus.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpget: snmpget.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpget.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpget.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpdelta: snmpdelta.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpdelta.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpdelta.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmptable: snmptable.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmptable.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmptable.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmptest: snmptest.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmptest.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmptest.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmptrapd: snmptrapd.o snmptrapd_handlers.o $(USELIBS)
- ${CC} -o $@ snmptrapd.o snmptrapd_handlers.o $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmptrapd.o snmptrapd_handlers.o $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmptrap: snmptrap.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmptrap.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmptrap.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
rm -f snmpinform
@@ -68,12 +70,12 @@
snmpset: snmpset.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpset.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpset.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpusm: snmpusm.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpusm.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpusm.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmpgetnext: snmpgetnext.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ snmpgetnext.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ snmpgetnext.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
encode_keychange: encode_keychange.o $(PARSEOBJS) $(USELIBS)
- ${CC} -o $@ encode_keychange.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
+ $(LIBTOOL) ${CC} -o $@ encode_keychange.o $(PARSEOBJS) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
@@ -91,6 +93,6 @@
done
- @for i in $(TARG) ; do $(INSTALL) $$i $(bindir) ; echo "install: installed $$i in $(bindir)" ; done
+ @for i in $(TARG) ; do $(LIBTOOL) $(INSTALL) $$i $(bindir) ; echo "install: installed $$i in $(bindir)" ; done
rm -f $(bindir)/snmpinform
(cd $(bindir) && $(LN_S) snmptrap snmpinform)
- @for i in $(SBINTARG) ; do $(INSTALL) $$i $(sbindir) ; echo "install: installed $$i in $(sbindir)" ; done
+ @for i in $(SBINTARG) ; do $(LIBTOOL) $(INSTALL) $$i $(sbindir) ; echo "install: installed $$i in $(sbindir)" ; done