pkgsrc/comms/asterisk16/patches/patch-Makefile
ryoon d58acc71a3 asterisk16: Update to 16.16.0
Changelog:
The following issues are resolved in this release:

Security bugs fixed in this release:

  * [ASTERISK-29219]       res_pjsip_diversion: Crash if Tel URI contains
                             History-Info
                             (Reported by Torrey Searle)

Bugs fixed in this release:

  * [ASTERISK-29229]       Stasis/messaging: text messages not dispatched to
                             all subscribers when using generic subscription
                             (Reported by Jean Aunis  Prescom)
  * [ASTERISK-29238]       chan_sip: SDP: Offers without any enabled stream
                             are accepted.
                             (Reported by Alexander Traud)
  * [ASTERISK-29237]       chan_sip: SDP: m=video is parsed even when
                             disabled.
                             (Reported by Alexander Traud)
  * [ASTERISK-29222]       chan_sip: Hold/Resume an sRTP call on a video
                             enabled user-agent.
                             (Reported by Alexander Traud)
  * [ASTERISK-29240]       chan_pjsip: Incoming PJSIP calls set global
                             SIPDOMAIN instead of a channel variable
                             (Reported by Ivan Poddubny)
  * [ASTERISK-27902]       chan_pjsip isnt updating hangupcause on 4XX
                             responses
                             (Reported by George Joseph)
  * [ASTERISK-28016]       PJSIP sends duplicate 183 Progress responses
                             (Reported by Alex Hermann)
  * [ASTERISK-28185]       chan_pjsip: Subsequent same responses are not
                             stopped
                             (Reported by Julien)
  * [ASTERISK-29230]       pjsip: Asterisk goes crazy and massively spams
                             logfile if registration cant be send
                             (Reported by Michael Maier)
  * [ASTERISK-29231]       pjsip: SIGSEGV in CLI if no trunk is registered
                             (Reported by Michael Maier)
  * [ASTERISK-29217]       LOCK() can grant the same lock to multiple
                             channels spuriously
                             (Reported by Jaco Kroon)
  * [ASTERISK-29201]       Crash occurs when Transfer and execute Hangup
                             before the Transfer result
                             (Reported by Dan Cropp)
  * [ASTERISK-28947]       Segmentation fault in mixmonitor_ds_destroy
                             (Reported by Robert Sutton)
  * [ASTERISK-29191]       tel: URI in Diversion header causes crash
                             (Reported by Mikhail Ivanov)
  * [ASTERISK-28883]       Spyee information ist missing in ChanSpyStop AMI
                             Event
                             (Reported by Hendrik Wedhorn)
  * [ASTERISK-29188]       null media causing the Asterisk crash
                             (Reported by sungtae kim)
  * [ASTERISK-29209]       Debug messages printed by scope trace might be
                             missing newlines
                             (Reported by Alexander Traud)
  * [ASTERISK-29024]       pjsip: Route Header in Cancel request incorrectly
                             set
                             (Reported by Flole Systems)
  * [ASTERISK-29211]       res_musiconhold: Segfault on realtime music on
                             hold without entries
                             (Reported by Nathan Bruning)
  * [ASTERISK-29022]       Crash when manipulating PJSIP invite dlg ref
                             counts
                             (Reported by Sean Bright)
  * [ASTERISK-29173]       Media cache URL requests allow infinite redirects
                             (Reported by Sean Bright)
  * [ASTERISK-29175]       res_pjsip_stir_shaken: Fix module description
                             (Reported by Stanislav Abramenkov)
  * [ASTERISK-29148]       AST_MODULE_INFO no, MODULEINFO depend
                             (Reported by Alexander Traud)
  * [ASTERISK-28798]       chan_sip: TCP/TLS client without server.
                             (Reported by Alexander Traud)
  * [ASTERISK-29165]       res_pjsip: malformed header Accept-Encoding in
                             OPTIONS response
                             (Reported by Alexander Greiner-Baer)
  * [ASTERISK-29161]       Incorrect setup of recall channels
                             (Reported by Boris P. Korzun)
  * [ASTERISK-29155]       app_queue: Deadlock between queues container and
                             individual queues
                             (Reported by George Joseph)

Improvements made in this release:


  * [ASTERISK-28549]       Two repeated 183
                             (Reported by Gant Liu)
  * [ASTERISK-29216]       contrib: systemd asterisk service for centos8 or
                             other newer linux versions
                             (Reported by Mark Petersen)
  * [ASTERISK-29143]       res_http_media_cache: HTTP media cache stored
                             hardcoded in /tmp
                             (Reported by laszlovl)
  * [ASTERISK-29118]       VoiceMail() should have an option to play
                             greetings as Early Media
                             (Reported by Juan Carlos Castro y Castro)
2021-02-11 02:20:18 +00:00

113 lines
4.8 KiB
Text

$NetBSD: patch-Makefile,v 1.3 2021/02/11 02:20:18 ryoon Exp $
--- Makefile.orig 2021-01-21 16:28:04.000000000 +0000
+++ Makefile
@@ -143,7 +143,7 @@ DEBUG=-g3
# Asterisk.conf is located in ASTETCDIR or by using the -C flag
# when starting Asterisk
-ASTCONFPATH=$(ASTETCDIR)/asterisk.conf
+ASTCONFPATH=$(ASTEXAMPLEDIR)/asterisk.conf
AGI_DIR=$(ASTDATADIR)/agi-bin
# If you use Apache, you may determine by a grep 'DocumentRoot' of your httpd.conf file
@@ -215,12 +215,6 @@ ifeq ($(AST_DEVMODE),yes)
endif
endif
-ifeq ($(OSARCH),NetBSD)
- _ASTCFLAGS+=-isystem /usr/pkg/include
-else ifneq ($(findstring BSD,$(OSARCH)),)
- _ASTCFLAGS+=-isystem /usr/local/include
-endif
-
ifeq ($(OSARCH),FreeBSD)
# -V is understood by BSD Make, not by GNU make.
BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
@@ -435,7 +429,6 @@ dist-clean: distclean
distclean: $(SUBDIRS_DIST_CLEAN) _clean
@$(MAKE) -C menuselect dist-clean
- @$(MAKE) -C sounds dist-clean
rm -f menuselect.makeopts makeopts menuselect-tree menuselect.makedeps
rm -f config.log config.status config.cache
rm -rf autom4te.cache
@@ -556,7 +549,7 @@ update:
NEWHEADERS=$(notdir $(wildcard include/asterisk/*.h))
OLDHEADERS=$(filter-out $(NEWHEADERS) $(notdir $(DESTDIR)$(ASTHEADERDIR)),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
-INSTALLDIRS="$(ASTLIBDIR)" "$(ASTMODDIR)" "$(ASTSBINDIR)" "$(ASTCACHEDIR)" "$(ASTETCDIR)" "$(ASTVARRUNDIR)" \
+INSTALLDIRS="$(ASTLIBDIR)" "$(ASTMODDIR)" "$(ASTSBINDIR)" "$(ASTCACHEDIR)" "$(ASTEXAMPLEDIR)" "$(ASTVARRUNDIR)" \
"$(ASTSPOOLDIR)" "$(ASTSPOOLDIR)/dictate" "$(ASTSPOOLDIR)/meetme" \
"$(ASTSPOOLDIR)/monitor" "$(ASTSPOOLDIR)/system" "$(ASTSPOOLDIR)/tmp" \
"$(ASTSPOOLDIR)/voicemail" "$(ASTSPOOLDIR)/recording" \
@@ -762,7 +755,7 @@ upgrade: bininstall
# (2) the extension to strip off
define INSTALL_CONFIGS
@for x in $(1)/*$(2); do \
- dst="$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x $(2)`"; \
+ dst="$(DESTDIR)$(ASTEXAMPLEDIR)/`$(BASENAME) $$x $(2)`"; \
if [ -f "$${dst}" ]; then \
if [ "$(OVERWRITE)" = "y" ]; then \
if cmp -s "$${dst}" "$$x" ; then \
@@ -781,7 +774,7 @@ define INSTALL_CONFIGS
if [ "$(OVERWRITE)" = "y" ]; then \
echo "Updating asterisk.conf" ; \
sed -e 's|^astcachedir.*$$|astcachedir => $(ASTCACHEDIR)|' \
- -e 's|^astetcdir.*$$|astetcdir => $(ASTETCDIR)|' \
+ -e 's|^astetcdir.*$$|astetcdir => $(ASTEXAMPLEDIR)|' \
-e 's|^astmoddir.*$$|astmoddir => $(ASTMODDIR)|' \
-e 's|^astvarlibdir.*$$|astvarlibdir => $(ASTVARLIBDIR)|' \
-e 's|^astdbdir.*$$|astdbdir => $(ASTDBDIR)|' \
@@ -819,15 +812,15 @@ install-configs:
# XXX why *.adsi is installed first ?
adsi:
@echo Installing adsi config files...
- $(INSTALL) -d "$(DESTDIR)$(ASTETCDIR)"
+ $(INSTALL) -d "$(DESTDIR)$(ASTEXAMPLEDIR)"
@for x in configs/samples/*.adsi; do \
- dst="$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`" ; \
+ dst="$(DESTDIR)$(ASTEXAMPLEDIR)/`$(BASENAME) $$x`" ; \
if [ -f "$${dst}" ] ; then \
echo "Overwriting $$x" ; \
else \
echo "Installing $$x" ; \
fi ; \
- $(INSTALL) -m 644 "$$x" "$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`" ; \
+ $(INSTALL) -m 644 "$$x" "$(DESTDIR)$(ASTEXAMPLEDIR)/`$(BASENAME) $$x`" ; \
done
samples: adsi
@@ -860,7 +853,7 @@ basic-pbx:
webvmail:
@[ -d "$(DESTDIR)$(HTTP_DOCSDIR)/" ] || ( printf "http docs directory not found.\nUpdate assignment of variable HTTP_DOCSDIR in Makefile!\n" && exit 1 )
@[ -d "$(DESTDIR)$(HTTP_CGIDIR)" ] || ( printf "cgi-bin directory not found.\nUpdate assignment of variable HTTP_CGIDIR in Makefile!\n" && exit 1 )
- $(INSTALL) -m 4755 contrib/scripts/vmail.cgi "$(DESTDIR)$(HTTP_CGIDIR)/vmail.cgi"
+ $(INSTALL) contrib/scripts/vmail.cgi "$(DESTDIR)$(HTTP_CGIDIR)/vmail"
$(INSTALL) -d "$(DESTDIR)$(HTTP_DOCSDIR)/_asterisk"
for x in images/*.gif; do \
$(INSTALL) -m 644 $$x "$(DESTDIR)$(HTTP_DOCSDIR)/_asterisk/"; \
@@ -910,11 +903,11 @@ endif
endif
install-logrotate:
- if [ ! -d "$(DESTDIR)$(ASTETCDIR)/../logrotate.d" ]; then \
- $(INSTALL) -d "$(DESTDIR)$(ASTETCDIR)/../logrotate.d" ; \
+ if [ ! -d "$(DESTDIR)$(ASTEXAMPLEDIR)/../logrotate.d" ]; then \
+ $(INSTALL) -d "$(DESTDIR)$(ASTEXAMPLEDIR)/../logrotate.d" ; \
fi
sed 's#__LOGDIR__#$(ASTLOGDIR)#g' < contrib/scripts/asterisk.logrotate | sed 's#__SBINDIR__#$(ASTSBINDIR)#g' > contrib/scripts/asterisk.logrotate.tmp
- $(INSTALL) -m 0644 contrib/scripts/asterisk.logrotate.tmp "$(DESTDIR)$(ASTETCDIR)/../logrotate.d/asterisk"
+ $(INSTALL) -m 0644 contrib/scripts/asterisk.logrotate.tmp "$(DESTDIR)$(ASTEXAMPLEDIR)/../logrotate.d/asterisk"
rm -f contrib/scripts/asterisk.logrotate.tmp
config:
@@ -1041,7 +1034,7 @@ uninstall-all: _uninstall uninstall-head
rm -rf "$(DESTDIR)$(ASTVARLIBDIR)"
rm -rf "$(DESTDIR)$(ASTDATADIR)"
rm -rf "$(DESTDIR)$(ASTSPOOLDIR)"
- rm -rf "$(DESTDIR)$(ASTETCDIR)"
+ rm -rf "$(DESTDIR)$(ASTEXAMPLEDIR)"
rm -rf "$(DESTDIR)$(ASTLOGDIR)"
menuconfig: menuselect