- LP64 and other portability issues - Find the correct <kafs.h> in order to get the right prototype for kafs_settoken_rxkad. - Find the correct <com_err.h> - Add support for -DMULTIPROCESSOR and other kernel compile options Bump PKGREVISION.
40 lines
1.4 KiB
Text
40 lines
1.4 KiB
Text
$NetBSD: patch-ak,v 1.7 2005/03/25 17:40:25 wennmach Exp $
|
|
|
|
Building afsdir_check exposes a buildlink3 bug. Since we don't
|
|
install afsdir_check, the simple work-around is not to build
|
|
afsdir_check at all.
|
|
|
|
Reorder libs: move libroken to the end.
|
|
|
|
|
|
--- arlad/Makefile.in.orig 2005-03-10 12:58:35.000000000 +0100
|
|
+++ arlad/Makefile.in 2005-03-10 13:00:21.000000000 +0100
|
|
@@ -25,7 +25,7 @@
|
|
|
|
ARLA_SBIN = arla-cli
|
|
ARLA_LIBEXEC = arlad
|
|
-NOINST_BIN = afsdir_check dump_state play_disco
|
|
+NOINST_BIN = dump_state play_disco
|
|
|
|
MANPAGES = \
|
|
AliasDB.5 \
|
|
@@ -78,7 +78,7 @@
|
|
|
|
LIBS_common_post= ../lib/ko/libko.la ../util/libarlautil.la \
|
|
../lib/vers/libvers.la \
|
|
- @LIB_roken@ $(RXKADLIB) $(KAFS_LIBS) @LIBS@
|
|
+ $(RXKADLIB) $(KAFS_LIBS) @LIBS@ @LIB_roken@
|
|
|
|
LIBS_arla-cli = $(LIBS_common) \
|
|
$(LIB_sl) @LIB_readline@ \
|
|
@@ -245,8 +245,8 @@
|
|
arla-cli: $(arla-cli_OBJS) $(LIBDEPENDS)
|
|
$(top_builddir)/libtool --mode=link $(CC) $(LDFLAGS) -o $@ $(arla-cli_OBJS) $(LIBS_arla-cli)
|
|
|
|
-afsdir_check: $(afsdir_check_OBJS)
|
|
- $(top_builddir)/libtool --mode=link $(CC) $(LDFLAGS) -o $@ $(afsdir_check_OBJS) $(LIBS_afsdir_check)
|
|
+#afsdir_check: $(afsdir_check_OBJS)
|
|
+# $(top_builddir)/libtool --mode=link $(CC) $(LDFLAGS) -o $@ $(afsdir_check_OBJS) $(LIBS_afsdir_check)
|
|
|
|
dump_state: $(dump_state_OBJS)
|
|
$(top_builddir)/libtool --mode=link $(CC) $(LDFLAGS) -o $@ $(dump_state_OBJS) $(LIBS_dump_state)
|