81f4e12abc
Linux. The readline buildlink3.mk file now pulls in the correct dependencies on its own. + Actually tell the configure script to use the readline dependency. + Add patch-ac which fixes the declaration of readline() to match the readline.h header (it takes a const char * argument). + Add full DESTDIR support. Bump the PKGREVISION to 2.
13 lines
459 B
Text
13 lines
459 B
Text
$NetBSD: patch-ac,v 1.1 2008/03/05 04:00:01 jlam Exp $
|
|
|
|
--- bc/scan.l.orig 2000-09-13 14:25:47.000000000 -0400
|
|
+++ bc/scan.l
|
|
@@ -143,7 +143,7 @@ static int rl_len = 0;
|
|
|
|
/* Definitions for readline access. */
|
|
extern FILE *rl_instream;
|
|
-_PROTOTYPE(char *readline, (char *));
|
|
+_PROTOTYPE(char *readline, (const char *));
|
|
|
|
/* rl_input puts upto MAX characters into BUF with the number put in
|
|
BUF placed in *RESULT. If the yy input file is the same as
|