pkgsrc/cad/iverilog/patches/patch-cadpli_Makefile
kamil 198b016345 Import iverilog (Icarus Verilog) 10.1.1 as cad/iverilog
It's a rename of cad/verilog to a better name.

Updated DESCR for new package:

Icarus Verilog is intended to compile ALL of the Verilog HDL as described in
the IEEE-1364 standard. Of course, it's not quite there yet. It does currently
handle a mix of structural and behavioral constructs.

Icarus Verilog is not aimed at being a simulator in the traditional sense, but
a compiler that generates code employed by back-end tools.

No objections to rename from <gdt>
2016-10-08 23:01:45 +00:00

17 lines
555 B
Text

$NetBSD: patch-cadpli_Makefile,v 1.1 2016/10/08 23:01:45 kamil Exp $
gcc -std=gnu99 -shared -L/usr/lib -Wl,-R/usr/lib -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -o cadpli.vpl cadpli.o ../libveriuser/libveriuser.o -L../vvp -lvpi
mkdir: dep: Not a directory
Makefile:52: recipe for target 'dep' failed
--- cadpli/Makefile.in~ 2013-08-20 04:10:31.000000000 +0900
+++ cadpli/Makefile.in 2013-12-20 22:03:29.000000000 +0900
@@ -51,7 +51,7 @@ check: all
dep:
mkdir dep
-%.o: %.c
+%.o: %.c dep
$(CC) $(CPPFLAGS) $(CFLAGS) @DEPENDENCY_FLAG@ -c $<
mv $*.d dep