pkgsrc/net/ed2k-gtk-gui/patches/patch-ac
2006-10-14 01:14:15 +00:00

88 lines
3.1 KiB
Text

$NetBSD: patch-ac,v 1.1 2006/10/14 01:21:48 rillig Exp $
--- configure.in.orig 2004-08-26 20:10:27.000000000 +0200
+++ configure.in 2006-10-14 03:20:03.000000000 +0200
@@ -58,12 +58,12 @@ dnl ====================================
AC_ARG_ENABLE(static-gnet2, [ --enable-static-gnet2 build and use gnet2 as shipped with the GUI source code, even if gnet2 was found], enable_gnetopt=yes , enable_gnetopt=no)
-if test "x$enable_gnetopt" == "xyes"
+if test "x$enable_gnetopt" = "xyes"
then
want_gnet2_opt=yes
fi
-if test "x$want_gnet2_opt" == "xyes"
+if test "x$want_gnet2_opt" = "xyes"
then
PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.0.0, ,
[ AC_MSG_ERROR([pkg-config could not find gthread-2.0 >= 2.0.0. Do you have the glib-2.x development packages installed? You need the glib2 and the glib2-devel packages (libglib2.0-0 and libglib2.0-dev on debian).])])
@@ -79,7 +79,7 @@ else
GTHREAD_CFLAGS=""
fi
-AM_CONDITIONAL([GNET_OPT], [test "x$want_gnet2_opt" == "xyes"])
+AM_CONDITIONAL([GNET_OPT], [test "x$want_gnet2_opt" = "xyes"])
AC_SUBST([GTK_CFLAGS GTK_LIBS GNET_CFLAGS GNET_LIBS GTHREAD_CFLAGS GTHREAD_LIBS])
@@ -152,7 +152,7 @@ darwin*)
AC_DEFINE(GNET_APPLE_DARWIN, 1, [Define if building on Apple Darwin])
dnl disable smart processing, see gnet's README.macosx
- if test "x$want_gnet2_opt" == "xyes"
+ if test "x$want_gnet2_opt" = "xyes"
then
GTHREAD_CFLAGS="-no-cpp-precomp $GTHREAD_CFLAGS"
fi
@@ -191,7 +191,7 @@ AC_SUBST([ICONS_CFLAGS I18N_CFLAGS GUI_C
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
-AM_CONDITIONAL([OS_WIN32], [test "x$winos" == "xyes"])
+AM_CONDITIONAL([OS_WIN32], [test "x$winos" = "xyes"])
AC_ARG_ENABLE(static-poll, [ --enable-static-poll build and use libpoll as shipped with the GUI source code, even if poll.h was found], enable_pollopt=yes , enable_pollopt=no)
@@ -200,16 +200,16 @@ dnl
dnl Windows select works only for sockets
dnl so poll-emulator doesn't make sense
dnl
-if test "x$winos" == "xno"; then
- if test "x$have_sys_poll_h" == "xno"
+if test "x$winos" = "xno"; then
+ if test "x$have_sys_poll_h" = "xno"
then
- if test "x$have_poll_h" == "xno"
+ if test "x$have_poll_h" = "xno"
then
AC_DEFINE_UNQUOTED(USE_POLL_EMULATOR,1,[Use libpoll (poll-emulator.c) that ships with the GUI source code])
fi
fi
- if test "x$enable_pollopt" == "xyes"
+ if test "x$enable_pollopt" = "xyes"
then
AC_DEFINE_UNQUOTED(USE_POLL_EMULATOR,1,[Use libpoll (poll-emulator.c) that ships with the GUI source code])
fi
@@ -228,7 +228,7 @@ AC_ARG_ENABLE(systray, [ --disable-syst
if test "x$enable_systray" != "xyes"; then
GUI_CFLAGS="-DGUI_DISABLE_SYSTRAY $GUI_CFLAGS"
- if test "x$systray_default" == "xyes"; then
+ if test "x$systray_default" = "xyes"; then
AC_MSG_NOTICE([Systray icon: DISABLED])
else
if test "x$macosx" = "xyes"; then
@@ -246,9 +246,9 @@ else
fi
-if test "x$want_gnet2_opt" == "xyes"
+if test "x$want_gnet2_opt" = "xyes"
then
- if test "x$enable_gnetopt" == "xyes"
+ if test "x$enable_gnetopt" = "xyes"
then
AC_MSG_NOTICE([Gnet2 library: build and link statically (--enable-static-gnet2 specified)])
else