pkgsrc/x11/kdebase2/patches/patch-bd
skrll a62b3e67a6 Update to KDE 2.2.1
With apologies to Al I wouldn't know where to start with a summary of the
changes between 2.1 and 2.2.1 - there are just too many. A couple of
hopefully static URLS that contain useful information are

http://www.kde.org/announcements/changelog2_1to2_2.html
http://www.kde.org/announcements/changelog2_2to2_2_1.html

Support for a.out for kde{libs,base} added by me. The libtool/a.out
combination doesn't like the linking of modules into binaries. A better
way of doing this will appear in future versions of KDE/pkgsrc.
2001-10-15 22:45:55 +00:00

40 lines
1.3 KiB
Text

$NetBSD: patch-bd,v 1.1 2001/10/15 22:46:01 skrll Exp $
--- kdeprint/kjobviewer/Makefile.am.orig Sun Jul 29 05:56:25 2001
+++ kdeprint/kjobviewer/Makefile.am
@@ -1,15 +1,20 @@
INCLUDES = $(all_includes)
bin_PROGRAMS = kjobviewer
-lib_LTLIBRARIES = kjobviewer.la
+lib_LTLIBRARIES = libkjobviewer_main.la kjobviewer.la
-kjobviewer_SOURCES = dummy.cpp
-kjobviewer_LDADD = kjobviewer.la
+kjobviewer_SOURCES = kjobviewer_main.cpp
+kjobviewer_LDADD = libkjobviewer_main.la
kjobviewer_LDFLAGS = $(KDE_RPATH) $(all_libraries)
-kjobviewer_la_SOURCES = kjobviewer.cpp main.cpp
+libkjobviewer_main_la_SOURCES = kjobviewer.cpp main.cpp
+libkjobviewer_main_la_METASOURCES = AUTO
+libkjobviewer_main_la_LIBADD = -lkdeprint_management $(LIB_KDEUI)
+libkjobviewer_main_la_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+kjobviewer_la_SOURCES = kjobviewer_main.cpp
kjobviewer_la_METASOURCES = AUTO
-kjobviewer_la_LIBADD = -lkdeprint_management $(LIB_KDEUI)
+kjobviewer_la_LIBADD = libkjobviewer_main.la
kjobviewer_la_LDFLAGS = -module -avoid-version $(all_libraries) $(KDE_RPATH)
noinst_HEADERS = kjobviewer.h
@@ -21,9 +26,6 @@
desktop_DATA = kjobviewer.desktop
desktopdir = $(kde_appsdir)/Utilities
-
-dummy.cpp:
- echo > dummy.cpp
messages: rc.cpp
$(XGETTEXT) *.cpp -o $(podir)/kjobviewer.pot