pkgsrc/x11/kdebase2/patches/patch-co
skrll a62b3e67a6 Update to KDE 2.2.1
With apologies to Al I wouldn't know where to start with a summary of the
changes between 2.1 and 2.2.1 - there are just too many. A couple of
hopefully static URLS that contain useful information are

http://www.kde.org/announcements/changelog2_1to2_2.html
http://www.kde.org/announcements/changelog2_2to2_2_1.html

Support for a.out for kde{libs,base} added by me. The libtool/a.out
combination doesn't like the linking of modules into binaries. A better
way of doing this will appear in future versions of KDE/pkgsrc.
2001-10-15 22:45:55 +00:00

39 lines
1.2 KiB
Text

$NetBSD: patch-co,v 1.1 2001/10/15 22:46:05 skrll Exp $
--- konqueror/client/Makefile.am.orig Wed Aug 9 18:10:36 2000
+++ konqueror/client/Makefile.am
@@ -1,12 +1,16 @@
AM_CPPFLAGS = -DQT_NO_CAST_ASCII
bin_PROGRAMS = kfmclient
-lib_LTLIBRARIES = kfmclient.la
+lib_LTLIBRARIES = libkfmclient_main.la kfmclient.la
INCLUDES= -I.. $(all_includes)
+libkfmclient_main_la_LDFLAGS = $(all_libraries)
+libkfmclient_main_la_LIBADD = $(LIB_KFILE)
+libkfmclient_main_la_SOURCES = kfmclient.cc KonquerorIface.stub KDesktopIface.stub
+
kfmclient_la_LDFLAGS = $(all_libraries) -module -avoid-version
-kfmclient_la_LIBADD = $(LIB_KFILE)
-kfmclient_la_SOURCES = kfmclient.cc KonquerorIface.stub KDesktopIface.stub
+kfmclient_la_LIBADD = libkfmclient_main.la
+kfmclient_la_SOURCES = kfmclient_main.cc
noinst_HEADERS = kfmclient.h
METASOURCES = AUTO
@@ -14,12 +18,9 @@
KonquerorIface_DIR = $(srcdir)/..
KDesktopIface_DIR = $(top_srcdir)/kdesktop
-kfmclient_SOURCES = dummy.cc
+kfmclient_SOURCES = kfmclient_main.cc
kfmclient_LDFLAGS = $(KDE_RPATH) $(all_libraries)
-kfmclient_LDADD = kfmclient.la
-
-dummy.cc:
- echo > dummy.cc
+kfmclient_LDADD = libkfmclient_main.la
messages:
$(XGETTEXT) -kaliasLocal *.h *.cc -o $(podir)/kfmclient.pot