pkgsrc/x11/kdebase2/patches/patch-ee
skrll a100f5d455 Update to KDE 2.2.2
Closes pkg/14728 from Mark Davies <mark@mcs.vuw.ac.nz>. Changes from him
with updates from myself.

From www.kde.org... The principal improvements over KDE 2.2.1, release two
months ago, include:

o security-related
	- SSL certificate loading
	- symlink vulnerability in .wmrc access by KDM introduced in 2.2
	- security problem with eFax (used by klprfax)
	- potential problem in PAM invocation by KDM
	- potential harmful side-effect of failed KDM session starts

o new features
	- added support for CodeWeavers' CrossOver plug-in (provides support
	  for QuickTime, etc.)
	- added support for the wheelmouse for scrolling through the
	  KGhostview PS/PDF viewer component
	- ability to search for multiple patterns at a time in the file
	  search dialog
	- debugging multi-threaded applications with KDevelop

o improvements/fixes
	- handling of HTTP links that redirect to FTP
	- POST using SSL through a proxy and sending headers through proxies
	- saving of recently-selected files in the file dialog
	- handling of non-ASCII characters over SMB
	- toolbar button captions with certain styles
	- selecting items with the mouse in Konqueror
	- sorting in Konqueror's textview
	- saving current settings as a theme in the theme manager
	- crashes in KMail with certain mails
	- crash on invoking the KDM chooser
	- non-Latin languages with KDevelop

performance
	- icon loading optimized
	- file dialog speedups
	- stop spinning SMB client processes
	- handling of large files in Kate
2001-12-03 15:37:14 +00:00

22 lines
736 B
Text

$NetBSD: patch-ee,v 1.2 2001/12/03 15:37:20 skrll Exp $
--- kwin/clients/redmond/Makefile.in.orig Sat Nov 10 07:58:38 2001
+++ kwin/clients/redmond/Makefile.in
@@ -278,7 +278,7 @@
kde_module_LTLIBRARIES = libkwinredmond.la
libkwinredmond_la_SOURCES = redmond.cpp
-libkwinredmond_la_LIBADD = ../../kwin.la
+libkwinredmond_la_LIBADD = ../../libkwin.la
libkwinredmond_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
#>- METASOURCES = AUTO
@@ -300,7 +300,7 @@
LIBS = @LIBS@
X_CFLAGS = @X_CFLAGS@
X_LIBS = @X_LIBS@
-libkwinredmond_la_DEPENDENCIES = ../../kwin.la
+libkwinredmond_la_DEPENDENCIES = ../../libkwin.la
#>- libkwinredmond_la_OBJECTS = redmond.lo
#>+ 5
libkwinredmond_la_final_OBJECTS = libkwinredmond_la.all_cpp.lo