pkgsrc/x11/xpns/patches/patch-filetraio_c
dholland 5fb20973bf Fix wrong hard-wired paths in patch-ab. (was using /usr/X11R6)
While here:
  - sprinkle stdlib.h widely to avoid undefined behavior calling malloc
  - fix randomizer setup (was calling srand() and then using random())
  - avoid installing a csh script, since we were replacing the entire
    contents of the file anyhow
  - add missing libXt and libX11 bl3.mk
  - add patch comments

PKGREVISION -> 4.
2012-06-16 04:00:53 +00:00

14 lines
371 B
Text

$NetBSD: patch-filetraio_c,v 1.1 2012/06/16 04:00:54 dholland Exp $
Use standard headers.
--- filetraio.c~ 1993-07-14 11:02:09.000000000 +0000
+++ filetraio.c
@@ -10,6 +10,7 @@
** DATUM : 14.03.93
**
*************************************************************************/
+#include <stdlib.h>
#include "filetraio.h"
#include "tra.h"
#include "misc.h"