While here: - sprinkle stdlib.h widely to avoid undefined behavior calling malloc - fix randomizer setup (was calling srand() and then using random()) - avoid installing a csh script, since we were replacing the entire contents of the file anyhow - add missing libXt and libX11 bl3.mk - add patch comments PKGREVISION -> 4.
15 lines
242 B
Text
15 lines
242 B
Text
$NetBSD: patch-halook_c,v 1.1 2012/06/16 04:00:54 dholland Exp $
|
|
|
|
Use standard headers.
|
|
|
|
--- halook.c~ 1993-07-14 11:02:16.000000000 +0000
|
|
+++ halook.c
|
|
@@ -18,7 +18,7 @@
|
|
#include "stewin.h"
|
|
|
|
#include <stdio.h>
|
|
-
|
|
+#include <stdlib.h>
|
|
|
|
|
|
|