pkgsrc/x11/xpns/patches/patch-halook_c
dholland 5fb20973bf Fix wrong hard-wired paths in patch-ab. (was using /usr/X11R6)
While here:
  - sprinkle stdlib.h widely to avoid undefined behavior calling malloc
  - fix randomizer setup (was calling srand() and then using random())
  - avoid installing a csh script, since we were replacing the entire
    contents of the file anyhow
  - add missing libXt and libX11 bl3.mk
  - add patch comments

PKGREVISION -> 4.
2012-06-16 04:00:53 +00:00

15 lines
242 B
Text

$NetBSD: patch-halook_c,v 1.1 2012/06/16 04:00:54 dholland Exp $
Use standard headers.
--- halook.c~ 1993-07-14 11:02:16.000000000 +0000
+++ halook.c
@@ -18,7 +18,7 @@
#include "stewin.h"
#include <stdio.h>
-
+#include <stdlib.h>