changes: many fixes and small improvements, most notably some memory leak and a use-after-free are fixed which might be security issues
64 lines
2.4 KiB
Text
64 lines
2.4 KiB
Text
$NetBSD: patch-ac,v 1.3 2015/01/15 19:39:16 drochner Exp $
|
|
|
|
--- configure.in.orig 2014-11-14 11:30:59.000000000 +0000
|
|
+++ configure.in
|
|
@@ -165,29 +165,12 @@ if test "$EMXOS2" = yes || test "$host_o
|
|
|
|
else
|
|
|
|
- $ID privoxy >/dev/null 2>/dev/null
|
|
- if test $? -ne 0 ; then
|
|
- AC_MSG_WARN(There is no user 'privoxy' on this system)
|
|
- fi
|
|
AC_MSG_CHECKING([for user])
|
|
AC_ARG_WITH(user,
|
|
[ --with-user=privoxy Set user under which privoxy will run],
|
|
[
|
|
- if test "x$withval" != "xyes"; then
|
|
- if test $ID = no ; then
|
|
- AC_MSG_ERROR(There is no 'id' program on this system)
|
|
- else
|
|
AC_MSG_RESULT($with_user)
|
|
- $ID $with_user 2>/dev/null >/dev/null
|
|
- if test $? -eq 0 ; then
|
|
USER=$with_user;
|
|
- else
|
|
- AC_MSG_ERROR(There is no user '$with_user' on this system)
|
|
- fi
|
|
- fi
|
|
- else
|
|
- AC_MSG_ERROR(We need a user if you give me this parameter)
|
|
- fi
|
|
],
|
|
[
|
|
if test $ID = no ; then
|
|
@@ -204,29 +187,6 @@ else
|
|
AC_ARG_WITH(group,
|
|
[ --with-group=privoxy Set group for privoxy],
|
|
[
|
|
- if test "x$withval" != "xyes"; then
|
|
- if test $BGROUPS = no ; then
|
|
- AC_MSG_ERROR(There is no 'groups' program on this system)
|
|
- else
|
|
- AC_MSG_RESULT($with_group)
|
|
- $BGROUPS $USER >/dev/null
|
|
- if test $? -eq 0 ; then
|
|
- for i in `$BGROUPS $USER | sed 's/.*: //' 2>/dev/null`; do
|
|
- if test "x$i" = "x$with_group" ; then
|
|
- GROUP=$with_group
|
|
- break
|
|
- fi
|
|
- done
|
|
- if test "x$GROUP" != "x$with_group" ; then
|
|
- AC_MSG_ERROR(The given value '$withval' does not match group entry)
|
|
- fi
|
|
- else
|
|
- AC_MSG_ERROR(There is no group entry for user '$USER')
|
|
- fi
|
|
- fi
|
|
- else
|
|
- AC_MSG_ERROR(We need a group if you give me this parameter)
|
|
- fi
|
|
],
|
|
[
|
|
if test $BGROUPS = no ; then
|