cbc9b0207d
Previously a special override header was used via an additional include path, but this extra include path was not exported to llvm-config so while llvm was ok, dependencies wouldn't find the header and fail. Instead just pull the changes directly inline into DataTypes.h so that they are available everywhere. Fixes the clang build on SunOS. Bump PKGREVISION.
15 lines
655 B
Text
15 lines
655 B
Text
$NetBSD: patch-CMakeLists.txt,v 1.1 2018/01/08 10:48:34 jperkin Exp $
|
|
|
|
Don't implement sys/regset.h workaround, fix source instead.
|
|
|
|
--- CMakeLists.txt.orig 2017-08-15 00:16:21.000000000 +0000
|
|
+++ CMakeLists.txt
|
|
@@ -809,7 +809,7 @@ endif(${CMAKE_SYSTEM_NAME} MATCHES "(Fre
|
|
|
|
if( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
|
|
# special hack for Solaris to handle crazy system sys/regset.h
|
|
- include_directories("${LLVM_MAIN_INCLUDE_DIR}/llvm/Support/Solaris")
|
|
+ #include_directories("${LLVM_MAIN_INCLUDE_DIR}/llvm/Support/Solaris")
|
|
endif( ${CMAKE_SYSTEM_NAME} MATCHES SunOS )
|
|
|
|
# Make sure we don't get -rdynamic in every binary. For those that need it,
|