37 lines
1.2 KiB
Text
37 lines
1.2 KiB
Text
$NetBSD: patch-fe,v 1.3 2008/08/15 14:06:54 cegger Exp $
|
|
|
|
--- ioemu/Makefile.target.orig 2008-08-14 15:26:06.000000000 +0000
|
|
+++ ioemu/Makefile.target
|
|
@@ -382,6 +382,7 @@ AUDIODRV += sdlaudio.o
|
|
endif
|
|
ifdef CONFIG_OSS
|
|
AUDIODRV += ossaudio.o
|
|
+LIBS += -lossaudio
|
|
endif
|
|
ifdef CONFIG_COREAUDIO
|
|
AUDIODRV += coreaudio.o
|
|
@@ -544,7 +545,7 @@ $(QEMU_SYSTEM): $(VL_OBJS) libqemu.a
|
|
ifdef CONFIG_STUBDOM
|
|
$(AR) rcs $@ $(VL_OBJS)
|
|
else
|
|
- $(CC) $(VL_LDFLAGS) -o $@ $^ $(LIBS) $(SDL_LIBS) $(COCOA_LIBS) $(VL_LIBS)
|
|
+ $(CC) $(VL_LDFLAGS) -Wl,-rpath,$(LIBDIR) -o $@ $^ $(LIBS) $(SDL_LIBS) $(COCOA_LIBS) $(VL_LIBS)
|
|
endif
|
|
|
|
cocoa.o: cocoa.m
|
|
@@ -660,12 +661,11 @@ distclean: clean
|
|
rm -rf config.mak config.h
|
|
|
|
install: all
|
|
- mkdir -p "$(DESTDIR)$(bindir)" "$(DESTDIR)$(configdir)"
|
|
+ $(BSD_INSTALL_PROGRAM_DIR) "$(DESTDIR)$(bindir)" "$(DESTDIR)$(configdir)"
|
|
ifneq ($(PROGS),)
|
|
- $(INSTALL_PROG) $(PROGS) "$(DESTDIR)$(bindir)"
|
|
+ $(BSD_INSTALL_PROGRAM) $(PROGS) "$(DESTDIR)$(bindir)"
|
|
endif
|
|
- $(INSTALL_PROG) $(TARGET_PATH)/qemu-dm.debug "$(DESTDIR)$(bindir)"
|
|
- $(INSTALL_PROG) $(TARGET_PATH)/qemu-ifup "$(DESTDIR)$(configdir)"
|
|
+ $(BSD_INSTALL_DATA) $(TARGET_PATH)/qemu-dm.debug "$(DESTDIR)$(bindir)"
|
|
|
|
ifneq ($(wildcard .depend),)
|
|
include .depend
|