29 lines
817 B
Text
29 lines
817 B
Text
$NetBSD: patch-aa,v 1.4 2001/12/15 20:37:53 agc Exp $
|
|
|
|
--- libtext/Makefile.orig Thu Jun 2 04:01:19 1994
|
|
+++ libtext/Makefile
|
|
@@ -5,14 +5,15 @@
|
|
#
|
|
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
|
|
# if your compiler supports posix-compatible compilation
|
|
-OS=-DSOLARIS
|
|
+OS=-DSUNOS -O2
|
|
+SAMDIR=${SAM_DIR}/include/sam
|
|
|
|
# add -Iincludedir for any include directories that need to be searched
|
|
# for posix header files
|
|
-INCS=-I. -I../include
|
|
+INCS=-I. -I${SAMDIR}
|
|
|
|
# add name of library orderer - use ":" if none exists
|
|
-RANLIB=:
|
|
+RANLIB=ranlib
|
|
|
|
# add name of library
|
|
AR=ar
|
|
@@ -38,4 +39,4 @@
|
|
|
|
install: $(LIB)
|
|
|
|
-$(OBJ): ../include/u.h ../include/libc.h ../include/libg.h ../include/frame.h ../include/text.h
|
|
+$(OBJ): ${SAMDIR}/u.h ${SAMDIR}/libc.h ${SAMDIR}/libg.h ${SAMDIR}/frame.h text.h
|