Changes since previous verion, from the NEWS file 2.8.x: - More scalable directory tree locking - Atomic open(O_TRUNC) support - Support big write requests on kernels 2.6.26 and newer - Out-of-tree fuse module removed - Better NFS exporting support - New ioctl and poll requests - New CUSE (Character Device in Userspace) interface - Allow umask processing in userspace - Added cache invalidation notifications - Bugfixes and small improvements 2.7.x: - Stacking support for the high level API - Add filename charset conversion module - Improved mounting 2.6.x! - Improved read characteristics (asynchronous reads) - Support for aborting filesystem connection - POSIX file locking support - Request interruption support - Building module for Linux kernels earlier than 2.6.9 not supported - Allow block device based filesystems to support swap files - Several bugs fixed, including a rare system hang on SMP
16 lines
695 B
Text
16 lines
695 B
Text
$NetBSD: patch-aa,v 1.2 2010/08/25 08:02:21 manu Exp $
|
|
|
|
mount.fuse is a script, not a binary
|
|
--- util/Makefile.in.orig 2010-08-24 10:08:52.000000000 +0200
|
|
+++ util/Makefile.in 2010-08-24 10:08:59.000000000 +0200
|
|
@@ -591,9 +591,9 @@
|
|
fi
|
|
|
|
install-exec-local:
|
|
$(mkdir_p) $(DESTDIR)$(MOUNT_FUSE_PATH)
|
|
- $(INSTALL_PROGRAM) $(srcdir)/mount.fuse $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
|
|
+ $(INSTALL_SCRIPT) $(srcdir)/mount.fuse $(DESTDIR)$(MOUNT_FUSE_PATH)/mount.fuse
|
|
$(mkdir_p) $(DESTDIR)$(INIT_D_PATH)
|
|
$(INSTALL_SCRIPT) $(srcdir)/init_script $(DESTDIR)$(INIT_D_PATH)/fuse
|
|
@if test -x /usr/sbin/update-rc.d; then \
|
|
echo "/usr/sbin/update-rc.d fuse start 34 S . start 41 0 6 . || true"; \
|