pkgsrc/x11/kdebase3/patches/patch-au
jlam efb93b17bd Merge changes in packages from the buildlink2 branch that have
buildlink2.mk files back into the main trunk.
2002-08-25 19:21:43 +00:00

15 lines
471 B
Text

$NetBSD: patch-au,v 1.2 2002/08/25 19:23:37 jlam Exp $
--- kcontrol/kcontrol/main.cpp.orig Wed May 8 19:21:01 2002
+++ kcontrol/kcontrol/main.cpp
@@ -86,7 +86,9 @@
delete toplevel;
}
-int main(int argc, char *argv[])
+extern "C" int kdemain(int argc, char *argv[]);
+
+int kdemain(int argc, char *argv[])
{
KAboutData aboutData( "kcontrol", I18N_NOOP("KDE Control Center"),
KCONTROL_VERSION, I18N_NOOP("The KDE Control Center"), KAboutData::License_GPL,