efb93b17bd
buildlink2.mk files back into the main trunk.
39 lines
1.2 KiB
Text
39 lines
1.2 KiB
Text
$NetBSD: patch-ci,v 1.2 2002/08/25 19:23:41 jlam Exp $
|
|
|
|
--- konqueror/client/Makefile.am.orig Wed Aug 9 18:10:36 2000
|
|
+++ konqueror/client/Makefile.am
|
|
@@ -1,12 +1,16 @@
|
|
AM_CPPFLAGS = -DQT_NO_CAST_ASCII
|
|
|
|
bin_PROGRAMS = kfmclient
|
|
-lib_LTLIBRARIES = kfmclient.la
|
|
+lib_LTLIBRARIES = libkfmclient_main.la kfmclient.la
|
|
|
|
INCLUDES= -I.. $(all_includes)
|
|
+libkfmclient_main_la_LDFLAGS = $(all_libraries)
|
|
+libkfmclient_main_la_LIBADD = $(LIB_KFILE)
|
|
+libkfmclient_main_la_SOURCES = kfmclient.cc KonquerorIface.stub KDesktopIface.stub
|
|
+
|
|
kfmclient_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
-kfmclient_la_LIBADD = $(LIB_KFILE)
|
|
-kfmclient_la_SOURCES = kfmclient.cc KonquerorIface.stub KDesktopIface.stub
|
|
+kfmclient_la_LIBADD = libkfmclient_main.la
|
|
+kfmclient_la_SOURCES = kfmclient_main.cc
|
|
|
|
noinst_HEADERS = kfmclient.h
|
|
METASOURCES = AUTO
|
|
@@ -14,12 +18,9 @@
|
|
KonquerorIface_DIR = $(srcdir)/..
|
|
KDesktopIface_DIR = $(top_srcdir)/kdesktop
|
|
|
|
-kfmclient_SOURCES = dummy.cc
|
|
+kfmclient_SOURCES = kfmclient_main.cc
|
|
kfmclient_LDFLAGS = $(KDE_RPATH) $(all_libraries)
|
|
-kfmclient_LDADD = kfmclient.la
|
|
-
|
|
-dummy.cc:
|
|
- echo > dummy.cc
|
|
+kfmclient_LDADD = libkfmclient_main.la
|
|
|
|
messages:
|
|
$(XGETTEXT) -kaliasLocal *.h *.cc -o $(podir)/kfmclient.pot
|