pkgsrc/x11/kdebase3/patches/patch-ek
jlam efb93b17bd Merge changes in packages from the buildlink2 branch that have
buildlink2.mk files back into the main trunk.
2002-08-25 19:21:43 +00:00

15 lines
479 B
Text

$NetBSD: patch-ek,v 1.2 2002/08/25 19:23:48 jlam Exp $
--- kxkb/kxkb.cpp.orig Sat Mar 2 22:03:52 2002
+++ kxkb/kxkb.cpp
@@ -483,7 +483,9 @@
const char * DESCRIPTION =
I18N_NOOP("A utility to switch keyboard maps.");
-int main(int argc, char *argv[])
+extern "C" int kdemain(int argc, char *argv[]);
+
+int kdemain(int argc, char *argv[])
{
KAboutData about("kxkb", I18N_NOOP("KDE Keyboard Tool"), "0.6",
DESCRIPTION, KAboutData::License_LGPL,