pkgsrc/x11/kdelibs3/patches/patch-ac
markd cce2ab9b81 Update to KDE 3.5.8
core libs
* Small performance improvements.
* Reworked KCmdLineArgs::makeURL to make "kpdf a:b" work when a:b is an
  existing file in the current directory.
* Be more robust against addressbar spoofing.
* A hostname may resolve to multiple addresses. When connection to one
  timeouts, we should not immediately give up. Instead, we try the other
  addresses.
http ioslave
* Fix crash on broken servers.
* Fix Connection failed Url Frame Redirection.
* Fix session cookies not always accepted.
* Fix persistent cookies are treated like session cookies.
* Fix a cross-site cookie injection vulnerability.
* Fix for correctly propagating HTTP response headers > 8K.
* Fix http responses containing just a header cause Konqueror to wait
  indefinitely for a response.
* Fix problem with cookies in konqueror when server specified as IP adress.
* Fix per-site cookie policy does not apply to cookies set for subdomains.
KHTML
* Fix handling of font-variant:inherit.
* Fix GMail/Firefox yet again.
* Fix confused cursor shapes if mail and new-window links appear on the
  same page.
* Fix cannot type text into boxes on riteaid.com.
* Optimize descendant selector matching.
* Fix invalid placing of image.
* Default to "UTF-8" per section 2 of the draft W3C "The XMLHttpRequest
  Object" specification.
kjs
* Do not convert accented latin1 characters into undrawable char in
  websites using advanced JavaScript.
2007-10-20 10:36:14 +00:00

13 lines
1.1 KiB
Text

$NetBSD: patch-ac,v 1.5 2007/10/20 10:36:15 markd Exp $
--- kdecore/Makefile.in.orig 2007-10-09 03:42:13.000000000 +1300
+++ kdecore/Makefile.in
@@ -697,7 +697,7 @@ libkdecore_la_SOURCES=libintl.cpp kappli
kqiodevicegzip_p.cpp ktimezones.cpp ksycoca_skel.cpp kappdcopiface_skel.cpp kdebugdcopiface_skel.cpp
libkdecore_la_LDFLAGS = $(QT_LDFLAGS) $(KDE_RPATH) $(KDE_MT_LDFLAGS) $(X_LDFLAGS) $(USER_LDFLAGS) -version-info 6:0:2 -no-undefined
-libkdecore_la_LIBADD = malloc/libklmalloc.la network/libkdecorenetwork.la $(SVGICON_LIB) ../dcop/libDCOP.la ../libltdl/libltdlc.la $(LIB_XEXT) $(LIBRESOLV) $(LIBUTIL) $(LIBART_LIBS) $(LIB_IDN) ../kdefx/libkdefx.la
+libkdecore_la_LIBADD = malloc/libklmalloc.la network/libkdecorenetwork.la $(SVGICON_LIB) ../dcop/libDCOP.la ../libltdl/libltdlc.la $(LIB_XEXT) $(LIBZ) $(LIBRESOLV) $(LIBUTIL) $(LIBART_LIBS) $(LIB_IDN) ../kdefx/libkdefx.la
libkdecore_la_NMCHECK = $(srcdir)/libkdecore.nmcheck
libkdecore_la_NMCHECKWEAK = $(srcdir)/libkdecore_weak.nmcheck $(srcdir)/libqt-mt_weak.nmcheck \
$(top_srcdir)/dcop/libDCOP_weak.nmcheck $(top_srcdir)/kdecore/standard_weak.nmcheck