pkgsrc/devel/xulrunner/patches/patch-mm
tnn 748e3fca55 Update to firefox-3.5.6. Security and bugfix release.
While here, switch NetBSD build from sunaudio to OSS emulation.
This greatly improves HTML5 video playback.
(Yes, we ought to fix the busted sunaudio support or PKG_OPTIONalize this.
 Perhaps another day.)

Advisories relating to this release:
MFSA 2009-71 GeckoActiveXObject exception messages can be used to
             enumerate installed COM objects
MFSA 2009-70 Privilege escalation via chrome window.opener
MFSA 2009-69 Location bar spoofing vulnerabilities
MFSA 2009-68 NTLM reflection vulnerability
MFSA 2009-67 Integer overflow, crash in libtheora video library
MFSA 2009-66 Memory safety fixes in liboggplay media library
MFSA 2009-65 Crashes with evidence of memory corruption (rv:1.9.1.6/ 1.9.0.16)
2009-12-16 08:18:32 +00:00

23 lines
576 B
Text

$NetBSD: patch-mm,v 1.2 2009/12/16 08:18:33 tnn Exp $
Don't link with -lCstd on Solaris when using GCC. From Tim Zingelman.
part of PR pkg/39085
--- toolkit/library/Makefile.in.orig 2009-12-02 05:28:58.000000000 +0100
+++ toolkit/library/Makefile.in
@@ -252,7 +252,14 @@ EXTRA_DSO_LDOPTS += -lbe -ltracker
endif
ifeq ($(OS_ARCH),SunOS)
-EXTRA_DSO_LDOPTS += -lelf -ldemangle -lCstd
+EXTRA_DSO_LDOPTS += -lelf -ldemangle
+ifndef GNU_CC
+EXTRA_DSO_LDOPTS += -lCstd
+endif
+endif
+
+ifeq ($(OS_ARCH),NetBSD)
+EXTRA_DSO_LDOPTS += -lossaudio
endif
ifeq ($(OS_ARCH),WINNT)