cd31561137
Changes sinec 4.1.1: * Extended DB & DBEnv set_get_returns_none functionality to take a "level" instead of a boolean flag. The boolean 0 and 1 values still have the same effect. A value of 2 extends the "return None instead of raising an exception" behaviour to the DBCursor set methods. This will become the default behaviour in pybsddb 4.2. * Updated documentation for set_get_returns_none. Regenerated the stale html docs from the text documentation. * Fixed a typo in DBCursor.join_item method that made it crash instead of returning a value. Obviously nobody uses it. Wrote a test case for join and join_item. * Added the dbobj wrapper for DBEnv set_timeout method. * Updated README.txt * Added the DBEnv.set_timeout method. * code cleanup to use python 2.x features in .py files * the standalone pybsddb distribution will install a module called bsddb3 while the module included with python >= 2.3 will be known as bsddb. * Shared all .py and .c source with the Python project. * Fixed DBTxn objects to raise an exception if they are used after the underlying DB_TXN handle becomes invalid. (rather than potentially causing a segfault) * Fixed module to work when compiled against a python without thread support. * Do not attempt to double-close DB cursor's whos underlying DB has already been closed (fixes a segfault). * Close DB objects when DB.open fails to prevent an exception about databases still being open when calling DBEnv.close.
19 lines
609 B
Text
19 lines
609 B
Text
$NetBSD: patch-aa,v 1.2 2004/02/10 17:56:55 minskim Exp $
|
|
|
|
--- setup.py.orig 2003-07-08 23:41:34.000000000 -0500
|
|
+++ setup.py
|
|
@@ -75,11 +75,11 @@ if os.name == 'posix':
|
|
|
|
# figure out from the base setting where the lib and .h are
|
|
if not incdir:
|
|
- incdir = os.path.join(BERKELEYDB_DIR, 'include')
|
|
+ incdir = os.path.join(BERKELEYDB_DIR, 'include/db4')
|
|
if not libdir:
|
|
libdir = os.path.join(BERKELEYDB_DIR, 'lib')
|
|
- if not '-ldb' in LIBS:
|
|
- libname = ['db']
|
|
+ if not '-ldb4' in LIBS:
|
|
+ libname = ['db4']
|
|
else:
|
|
libname = []
|
|
utils = []
|