a7c1be6a61
Pkgsrc changes: * Get rid of ruby dependencies, since the validator is no longer included in OpenDNSSEC * Adapt PLIST to changes in installed files * Add a patch so that the database migration scripts are installed as part of the package Upstream notable changes: * SUPPORT-58: Extend ods-signer sign <zone> with -serial <nr> so that the user can specify the SOA serial to use in the signed zone [OPENDNSSEC-401]. * OPENDNSSEC-91: Make the keytype flag required when rolling keys Bugfixes: * SUPPORT-60: Fix datecounter in case inbound serial is higher than outbound serial [OPENDNSSEC-420]. * OPENDNSSEC-247: Signer Engine: TTL on NSEC3 was not updated on SOA Minimum change. * OPENDNSSEC-421: Signer Engine: Fix assertion error in case NSEC3 hash algorithm in signconf is not SHA1. * OPENDNSSEC-421: ods-kaspcheck: Check whether NSEC3 hash algorithm in kasp is valid. * Bugfix: The time when inbound serial is acquired was reset invalidly, could cause OpenDNSSEC wanting AXFR responses while requesting IXFR (thanks Stuart Lau). * Bugfix: Fix malform in Outbound IXFR/TCP subsequent packet (thanks Stuart Lau). * OPENDNSSEC-398: The ods-ksmutil key rollover command does not work correctly when rolling all keys using the -policy option
48 lines
2.1 KiB
Text
48 lines
2.1 KiB
Text
$NetBSD: patch-aa,v 1.7 2013/08/22 11:05:45 he Exp $
|
|
|
|
Install sample configurations in another directory.
|
|
|
|
--- conf/Makefile.in.orig 2013-06-27 08:04:17.000000000 +0000
|
|
+++ conf/Makefile.in
|
|
@@ -299,6 +299,7 @@ sbindir = @sbindir@
|
|
sharedstatedir = @sharedstatedir@
|
|
srcdir = @srcdir@
|
|
sysconfdir = @sysconfdir@/opendnssec
|
|
+EGDIR=@EGDIR@
|
|
target_alias = @target_alias@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
@@ -568,19 +569,20 @@ regress: $(RNG)
|
|
(echo "kasp.xml built")
|
|
|
|
install-data-hook:
|
|
- test -d ${DESTDIR}${sysconfdir} || mkdir -p ${DESTDIR}${sysconfdir}
|
|
- test -f ${DESTDIR}${sysconfdir}/conf.xml || \
|
|
- ${INSTALL_DATA} -m 0640 conf.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} -m 640 conf.xml ${DESTDIR}${sysconfdir}/conf.xml.sample
|
|
- test -f ${DESTDIR}${sysconfdir}/addns.xml || \
|
|
- ${INSTALL_DATA} addns.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} addns.xml ${DESTDIR}${sysconfdir}/addns.xml.sample
|
|
- test -f ${DESTDIR}${sysconfdir}/zonelist.xml || \
|
|
- ${INSTALL_DATA} zonelist.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} zonelist.xml ${DESTDIR}${sysconfdir}/zonelist.xml.sample
|
|
- test -f ${DESTDIR}${sysconfdir}/kasp.xml || \
|
|
- ${INSTALL_DATA} kasp.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} kasp.xml ${DESTDIR}${sysconfdir}/kasp.xml.sample
|
|
+ test -d ${DESTDIR}${EGDIR} || mkdir -p ${DESTDIR}${EGDIR}
|
|
+ test -f ${DESTDIR}${EGDIR}/conf.xml || \
|
|
+ ${INSTALL_DATA} -m 0640 conf.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} -m 640 conf.xml ${DESTDIR}${EGDIR}/conf.xml.sample
|
|
+ test -f ${DESTDIR}${EGDIR}/addns.xml || \
|
|
+ ${INSTALL_DATA} addns.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} addns.xml ${DESTDIR}${EGDIR}/addns.xml.sample
|
|
+ test -f ${DESTDIR}${EGDIR}/zonelist.xml || \
|
|
+ ${INSTALL_DATA} zonelist.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} zonelist.xml ${DESTDIR}${EGDIR}/zonelist.xml.sample
|
|
+ test -f ${DESTDIR}${EGDIR}/kasp.xml || \
|
|
+ ${INSTALL_DATA} kasp.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} kasp.xml ${DESTDIR}${EGDIR}/kasp.xml.sample
|
|
+
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|