1c54d9eba3
Clean up Makefile for readibility. Add SMF manifest. Changes in 0.9.7: - Fix server-to-server interoperability issue with Isode M-Link (since 0.9.6) - Fix traceback in 'prosodyctl about' command with LuaRocks 2.2.0+ installed Changes in 0.9.6: - certmanager, net.http: Disable SSLv3 by default - net.http.parser: Support status code 101 and allow handling of the received data by plugins - util.filters: Ignore filters being added twice (fixes issues on removal, i.e. when some plugins are reloaded/unloaded) - mod_s2s: Close offending s2s streams missing an 'id' attribute with a stream error instead of throwing an unhandled error - Networking API: Add 'ondetach' callback for listener objects, to prevent leaks when connections have their listener changed - core.stanza_router: Stricter validation of stanzas - mod_admin_adhoc: Mark 'accountjids' field as required in 'end user sessions' command (thanks Lloyd) - mod_admin_adhoc: Add required to field in user deletion form too - net.dns: Avoid duplicate cache entries - util.stanza: Escape newlines and tabs (\r\n\t) when serializing stanzas. - util/dataforms: Make sure we iterate over field tags only - mod_s2s: Capitalize log message - mod_pubsub: Fix error type of 'forbidden' (change from 'cancel' to 'auth') Changes in 0.9.5: - C2S: Fix traceback if a client opens a stream to component, which could cause a crash in combination with some versions of LuaEvent - C2S, S2S: Log received invalid stream headers - S2S: Fix case where stream headers were sometimes sent twice - DNS: Ensure all pending requests get notified of a timeout when looking up a record - DNS: Fix duplicated cache insertions by limiting outstanding queries per name to one - xmppstream: Disable LuaExpat's buffering - xmppstream: Disable CharacterData merging after stream restarts - xmppstream: Pass invalid stream headers to error handling - Privacy lists: Correctly sort privacy list rules by order - prosody: Check dependencies later in the startup sequence - Config: Delay importing LuaFileSystem until needed by an Include line - Config: Normalize VirtualHost and Component names - prosodyctl: Normalize JIDs for adduser/passwd/deluser - POSIX: Fix error reporting from disk space allocation - POSIX: Verify that 'pidfile' is a string, show friendly error otherwise - Dependency checking: Check that prosody is running under Lua 5.1. We don't currently support any other versions. (LuaJIT identifies as 5.1) - Compliance: Reset stream ID when resetting stream - Compression: Log compression setup errors - Console: Fix commands for adding and replacing name servers - Console MUC commands: Fix error when a non-existent host is entered - Filters: Prevent filters from being added twice - Network: Transfer all available data between linked sockets - dataforms: Add support for XEP-0221: Data Forms Media Element
24 lines
708 B
Text
24 lines
708 B
Text
$NetBSD: patch-util-src_Makefile,v 1.1 2014/11/27 10:18:20 fhajny Exp $
|
|
|
|
We need libsocket on SunOS at least, for getifaddrs.
|
|
--- util-src/Makefile.orig 2014-10-24 22:30:55.000000000 +0000
|
|
+++ util-src/Makefile
|
|
@@ -6,6 +6,7 @@ LUA_INCDIR?=/usr/include/lua$(LUA_SUFFIX
|
|
LUA_LIB?=lua$(LUA_SUFFIX)
|
|
IDN_LIB?=idn
|
|
OPENSSL_LIB?=crypto
|
|
+SOCKET_LIB?=
|
|
CC?=gcc
|
|
CXX?=g++
|
|
LD?=gcc
|
|
@@ -32,6 +33,10 @@ hashes.so: hashes.o
|
|
MACOSX_DEPLOYMENT_TARGET="10.3"; export MACOSX_DEPLOYMENT_TARGET;
|
|
$(CC) -o $@ $< $(LDFLAGS) -l$(OPENSSL_LIB)
|
|
|
|
+net.so: net.o
|
|
+ MACOSX_DEPLOYMENT_TARGET="10.3"; export MACOSX_DEPLOYMENT_TARGET;
|
|
+ $(CC) -o $@ $< $(LDFLAGS) $(SOCKET_LIB)
|
|
+
|
|
.c.o:
|
|
$(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o $@ $<
|
|
|