0b332f8d36
Changes since 0.8 are not documented except in the ChangeLog. Changes from Version 0.7 to 0.8 - Fixed lot of bugs, especially in nfs code - Series 3 _should_ work again. - Added support for KDE (KDE >= 2.1) - Added KDE Application "kpsion" Changes from Version 0.6 to 0.7 - Changed timezone-stuff again. With S5, now the machine-info is evaluated. This info holds the Psion's time-offset so that we are able to calculate the offset correctly, regardless of the Psion's setting. All that is done in a new class PsiTime. For S3, a Fallback is provided using an Env-Variable "PSI_TZ" which can be set to the Psion's time-offset in seconds. - Added lots of rpc related stuff: - Implemented a procfs-like subdir in plpnfsd. Processes can be examined and misc. parameters can be examined/changed using the entries in <psionMountDir>/proc/ Several parameters can now be changed on the fly: attribute-cache timeout in seconds: proc/acache (rw) debuglevel: proc/debuglevel (rw) directory-cache timeout in seconds: proc/dcache (rw) Psion's owner-info: proc/owner (ro) Unix-owner of mounted directory: proc/unixowner (rw) Stopping of plpnfsd has now changed: Old: reference /mnt/psion/exit New: echo stop > /mnt/psion/proc/exit This should be safer than accidentally referencing a file. For every process running on the psion, a subdir in proc/ is created with two files "cmd" and "args" (both ro). cmd is the process-name, args is it's commandline. - Added machinfo command in plpftp for displaying lot of interesting information about S5. (E.g. battery status etc.) - Added killsave and runrestore to plpftpd. Both take a unix file as argument. killsave kills all processes on the Psion and saves restart-information to the specified file. runrestore reads a file created by killsave and starts all processes saved in this file. -> Functionality similar to the behavior of PsiWin before/after backup.
13 lines
544 B
Text
13 lines
544 B
Text
$NetBSD: patch-ap,v 1.1 2004/09/08 12:14:59 wiz Exp $
|
|
|
|
--- plpftp/Makefile.in.orig 2003-02-04 11:27:22.000000000 +0100
|
|
+++ plpftp/Makefile.in
|
|
@@ -209,7 +209,7 @@ x_libraries = @x_libraries@
|
|
INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl
|
|
|
|
bin_PROGRAMS = plpftp
|
|
-plpftp_LDADD = $(LIB_PLP) $(LIBREADLINE) $(LIBHISTORY) $(INTLLIBS)
|
|
+plpftp_LDADD = $(LIB_PLP) $(LIBREADLINE) $(LIBHISTORY) $(INTLLIBS) -ltermcap
|
|
plpftp_SOURCES = ftp.cc main.cc rlcrap.c
|
|
EXTRA_DIST = ftp.h rlcrap.h
|
|
mkinstalldirs = $(SHELL) $(top_srcdir)/conf/mkinstalldirs
|