95 lines
3.9 KiB
Text
95 lines
3.9 KiB
Text
$NetBSD: patch-aa,v 1.4 2009/03/18 12:40:52 drochner Exp $
|
|
|
|
--- configure.ac.orig 2008-06-05 23:56:16 +0300
|
|
+++ configure.ac 2009-03-18 05:25:38 +0200
|
|
@@ -41,14 +41,14 @@ AC_ARG_WITH([gnome],
|
|
[AS_HELP_STRING([--with-gnome],
|
|
[build GNOME configuration plugin @<:@automatic@:>@])],
|
|
[],
|
|
- [test x$have_gconf == xyes &&
|
|
- test x$have_x11 == xyes &&
|
|
- test x$have_xmu == xyes &&
|
|
+ [test x$have_gconf = xyes &&
|
|
+ test x$have_x11 = xyes &&
|
|
+ test x$have_xmu = xyes &&
|
|
with_gnome=yes])
|
|
if test x$with_gnome = xyes; then
|
|
- if test x$have_gconf == xyes && \
|
|
- test x$have_x11 == xyes && \
|
|
- test x$have_xmu == xyes; then
|
|
+ if test x$have_gconf = xyes && \
|
|
+ test x$have_x11 = xyes && \
|
|
+ test x$have_xmu = xyes; then
|
|
GNOME_CFLAGS="$x11_CFLAGS $xmu_CFLAGS $gconf_CFLAGS"
|
|
GNOME_LIBS="$x11_LIBS $xmu_LIBS $gconf_LIBS"
|
|
AC_SUBST(GNOME_CFLAGS)
|
|
@@ -67,12 +67,12 @@ AC_ARG_WITH([kde],
|
|
[AS_HELP_STRING([--with-kde],
|
|
[build KDE configuration plugin @<:@automatic@:>@])],
|
|
[],
|
|
- [test x$have_x11 == xyes &&
|
|
- test x$have_xmu == xyes &&
|
|
+ [test x$have_x11 = xyes &&
|
|
+ test x$have_xmu = xyes &&
|
|
with_kde=yes])
|
|
if test x$with_kde = xyes; then
|
|
- if test x$have_x11 == xyes && \
|
|
- test x$have_xmu == xyes; then
|
|
+ if test x$have_x11 = xyes && \
|
|
+ test x$have_xmu = xyes; then
|
|
KDE_CFLAGS="$x11_CFLAGS $xmu_CFLAGS"
|
|
KDE_LIBS="$x11_LIBS $xmu_LIBS"
|
|
AC_SUBST(KDE_CFLAGS)
|
|
@@ -91,9 +91,9 @@ AC_ARG_WITH([webkit],
|
|
[AS_HELP_STRING([--with-webkit],
|
|
[build WebKit JavaScriptCore PAC runner plugin @<:@automatic@:>@])],
|
|
[],
|
|
- [test x$have_webkit == xyes && with_webkit=yes])
|
|
+ [test x$have_webkit = xyes && with_webkit=yes])
|
|
if test x$with_webkit = xyes; then
|
|
- if test x$have_webkit == xyes; then
|
|
+ if test x$have_webkit = xyes; then
|
|
WEBKIT_CFLAGS="$webkit_CFLAGS"
|
|
WEBKIT_LIBS="$webkit_LIBS"
|
|
AC_SUBST(WEBKIT_CFLAGS)
|
|
@@ -112,9 +112,9 @@ AC_ARG_WITH([mozjs],
|
|
[AS_HELP_STRING([--with-mozjs],
|
|
[build Mozilla JavaScript PAC runner plugin @<:@automatic@:>@])],
|
|
[],
|
|
- [test x$have_mozjs == xyes && with_mozjs=yes])
|
|
+ [test x$have_mozjs = xyes && with_mozjs=yes])
|
|
if test x$with_mozjs = xyes; then
|
|
- if test x$have_mozjs == xyes; then
|
|
+ if test x$have_mozjs = xyes; then
|
|
MOZJS_CFLAGS="$mozjs_CFLAGS"
|
|
MOZJS_LIBS="$mozjs_LIBS"
|
|
AC_SUBST(MOZJS_CFLAGS)
|
|
@@ -133,9 +133,9 @@ AC_ARG_WITH([networkmanager],
|
|
[AS_HELP_STRING([--with-networkmanager],
|
|
[build NetworkManager plugin @<:@automatic@:>@])],
|
|
[],
|
|
- [test x$have_networkmanager == xyes && with_networkmanager=yes])
|
|
+ [test x$have_networkmanager = xyes && with_networkmanager=yes])
|
|
if test x$with_networkmanager = xyes; then
|
|
- if test x$have_networkmanager == xyes; then
|
|
+ if test x$have_networkmanager = xyes; then
|
|
NETWORKMANAGER_CFLAGS="$NetworkManager_CFLAGS"
|
|
NETWORKMANAGER_LIBS="$NetworkManager_LIBS"
|
|
AC_SUBST(NETWORKMANAGER_CFLAGS)
|
|
@@ -176,12 +176,15 @@ AC_C_CONST
|
|
AC_TYPE_SIZE_T
|
|
PLUGINDIR=$libdir/$PACKAGE_NAME/$PACKAGE_VERSION/plugins
|
|
AC_SUBST(PLUGINDIR)
|
|
-CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=1"
|
|
+CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=200112"
|
|
|
|
### Checks for library functions.
|
|
AC_FUNC_MALLOC
|
|
#AC_CHECK_FUNCS([gethostbyname gethostname memset socket strdup strstr])
|
|
|
|
+AC_CHECK_LIB(dl, dlopen, DL_LIBS="-ldl")
|
|
+AC_SUBST(DL_LIBS)
|
|
+
|
|
AC_CONFIG_FILES([libproxy-1.0.pc Makefile src/Makefile src/lib/Makefile
|
|
src/plugins/Makefile src/bin/Makefile src/bindings/Makefile
|
|
src/bindings/python/Makefile src/bindings/java/Makefile
|