pkgsrc/emulators/palmosemulator/patches/patch-ah
dsainty b494ed5cbf palmosemulator-3.5nb1. Pull in some changes suggested by Thomas Runge in
PR#19006: use the pkgsrc libjpeg instead of a local copy, and patch a bug in
the serial device file descriptor handling.

Also up the emulated "CPU idle" delay from 10ms to 100ms.  For some reason the
former saturates the CPU (on a Celeron 700 system), but with the latter the
program idles at near 0%.  This patch is probably not required for native
threads.  Mileage may vary...
2003-01-05 03:31:25 +00:00

36 lines
1.3 KiB
Text

$NetBSD: patch-ah,v 1.1 2003/01/05 03:31:25 dsainty Exp $
Use the libjpeg package, instead of a local copy.
--- BuildUnix/Makefile.am.orig Sat Mar 30 01:11:19 2002
+++ BuildUnix/Makefile.am Wed Jan 1 17:27:26 2003
@@ -4,7 +4,7 @@
## All rights reserved.
## ======================================================================================
-SUBDIRS = Gzip jpeg espws-2.0
+SUBDIRS = Gzip espws-2.0
SUFFIXES = .cpp
@@ -37,7 +37,6 @@
INCLUDES += -I$(srcdir)/../SrcShared/Palm/Platform/Incs/Core/UI
INCLUDES += -I$(srcdir)/../SrcShared/Palm/Platform/Incs/Libraries
INCLUDES += -I$(srcdir)/../SrcShared/Gzip
-INCLUDES += -I$(srcdir)/../SrcShared/jpeg
INCLUDES += -I$(srcdir)/../SrcShared/omnithread
INCLUDES += -I$(srcdir)/../SrcShared/Patches
INCLUDES += -I$(srcdir)/../SrcShared/UAE
@@ -403,10 +402,10 @@
bin_PROGRAMS = pose
pose_LDADD = $(srcdir)/Gzip/libposergzip.a
-pose_LDADD += $(srcdir)/jpeg/libposerjpeg.a
pose_LDADD += $(srcdir)/espws-2.0/libposerespws.a
+pose_LDADD += -ljpeg
pose_LDADD += -lfltk
-pose_LDADD += -L/usr/local/lib $(X_LIBS) -lXext -lX11 $(THREAD_LIBS) $(GLLIB) -lm
+pose_LDADD += $(X_LIBS) -lXext -lX11 $(THREAD_LIBS) $(GLLIB) -lm
pose_SOURCES = $(SRC_UNIX) $(SRC_UNIX_GEN) $(SRC_SHARED) $(SRC_SHARED_HARDWARE)
pose_SOURCES += $(SRC_PATCHES) $(SRC_TRG) $(SRC_UAE) $(SRC_PALM) $(SRC_THREAD)