pkgsrc/comms/conserver8/patches/patch-ac
wiz 2bd66436da Fix bug reported by Chris Ross on pkgsrc-users (patch-ac).
While here, split off options into options.mk, convert to user-destdir,
and add VARBASE to BUILD_DEFS.

Bump PKGREVISION.
2009-06-14 07:52:51 +00:00

13 lines
407 B
Text

$NetBSD: patch-ac,v 1.1 2009/06/14 07:52:51 wiz Exp $
--- conserver/cutil.c.orig 2006-12-26 07:27:34.000000000 +0000
+++ conserver/cutil.c
@@ -2283,7 +2283,7 @@ ProbeInterfaces(bindAddr)
if ((ifc.ifc_len - r) < sizeof(*ifr))
break;
#ifdef HAVE_SA_LEN
- if (sa->sa_len > sizeof(ifr->ifr_addr))
+ if (sa->sa_len > sizeof(ifr->ifr_ifru))
r += sizeof(ifr->ifr_name) + sa->sa_len;
else
#endif