pkgsrc/editors/emacs20/patches/patch-aj
joerg bd9ece0564 Add DragonFly support. Fix errno. Remove patch-ac, it gets
overriden by the GNU_CONFIGURE magic anyway.
2006-01-04 17:00:32 +00:00

171 lines
4.6 KiB
Text

$NetBSD: patch-aj,v 1.2 2006/01/04 17:00:32 joerg Exp $
--- src/process.c.orig 2000-05-23 19:10:16.000000000 +0000
+++ src/process.c
@@ -1,7 +1,18 @@
+/*
+ * Locally hacked process.c to add ipv6 support. -wsr
+ *
+ * The configure.in file should define "HAVE_GETADDRINFO" if it is found
+ * in libc.
+ *
+ */
+
/* Asynchronous subprocess control for GNU Emacs.
Copyright (C) 1985, 86, 87, 88, 93, 94, 95, 96, 1998
Free Software Foundation, Inc.
+ ipv6 changes are
+ Copyright (C) 1999 Wolfgang S. Rupprecht
+
This file is part of GNU Emacs.
GNU Emacs is free software; you can redistribute it and/or modify
@@ -147,7 +158,6 @@ Lisp_Object Qlast_nonmenu_event;
#include "syswait.h"
-extern int errno;
extern char *strerror ();
#ifdef VMS
extern char *sys_errlist[];
@@ -1810,15 +1820,21 @@ Fourth arg SERVICE is name of the servic
{
Lisp_Object proc;
register int i;
+#ifdef HAVE_GETADDRINFO
+ struct addrinfo hints, *res, *lres;
+ int ret = 0;
+ int xerrno = 0;
+ char *portstring, portbuf [128];
+#else /* HAVE_GETADDRINFO */
struct sockaddr_in address;
struct servent *svc_info;
struct hostent *host_info_ptr, host_info;
char *(addr_list[2]);
IN_ADDR numeric_addr;
- int s, outch, inch;
- char errstring[80];
- int port;
struct hostent host_info_fixed;
+ int port;
+#endif /* HAVE_GETADDRINFO */
+ int s = -1, outch, inch;
struct gcpro gcpro1, gcpro2, gcpro3, gcpro4;
int retry = 0;
int count = specpdl_ptr - specpdl;
@@ -1831,6 +1847,22 @@ Fourth arg SERVICE is name of the servic
GCPRO4 (name, buffer, host, service);
CHECK_STRING (name, 0);
CHECK_STRING (host, 0);
+
+#ifdef HAVE_GETADDRINFO
+ /*
+ * caution: service can either be a string or int.
+ * Convert to a C string for later use by getaddrinfo.
+ */
+ if (INTEGERP (service)) {
+ snprintf (portbuf, sizeof (portbuf), "%d", XINT (service));
+ portstring = portbuf;
+ }
+ else
+ {
+ CHECK_STRING (service, 0);
+ portstring = XSTRING (service)->data;
+ }
+#else /* HAVE_GETADDRINFO */
if (INTEGERP (service))
port = htons ((unsigned short) XINT (service));
else
@@ -1841,6 +1873,7 @@ Fourth arg SERVICE is name of the servic
error ("Unknown service \"%s\"", XSTRING (service)->data);
port = svc_info->s_port;
}
+#endif /* HAVE_GETADDRINFO */
/* Slow down polling to every ten seconds.
Some kernels have a bug which causes retrying connect to fail
@@ -1850,6 +1883,75 @@ Fourth arg SERVICE is name of the servic
#endif
#ifndef TERM
+#ifdef HAVE_GETADDRINFO /* We have a modern OS. -wsr */
+ immediate_quit = 1;
+ QUIT;
+ memset(&hints, 0, sizeof(hints));
+ hints.ai_flags = 0;
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_socktype = SOCK_STREAM;
+ hints.ai_protocol = 0;
+ ret = getaddrinfo(XSTRING (host)->data, portstring, &hints, &res);
+ if (ret)
+ error("%s/%s %s", XSTRING (host)->data, portstring, gai_strerror(ret));
+ immediate_quit = 0;
+
+ for (lres = res; lres ; lres = lres->ai_next)
+ {
+ s = socket(lres->ai_family, lres->ai_socktype, lres->ai_protocol);
+ if (s < 0)
+ {
+ xerrno = errno;
+ continue;
+ }
+
+ /* Kernel bugs (on Ultrix at least) cause lossage (not just EINTR)
+ when connect is interrupted. So let's not let it get interrupted.
+ Note we do not turn off polling, because polling is only used
+ when not interrupt_input, and thus not normally used on the systems
+ which have this bug. On systems which use polling, there's no way
+ to quit if polling is turned off. */
+ if (interrupt_input)
+ unrequest_sigio ();
+
+ loop:
+ immediate_quit = 1;
+ QUIT;
+
+ if (connect(s, lres->ai_addr, lres->ai_addrlen) == 0 ||
+ errno == EISCONN)
+ break;
+
+ xerrno = errno;
+ immediate_quit = 0;
+
+ if (errno == EINTR)
+ goto loop;
+ if (errno == EADDRINUSE && retry < 20)
+ {
+ /* A delay here is needed on some FreeBSD systems,
+ and it is harmless, since this retrying takes time anyway
+ and should be infrequent. */
+ Fsleep_for (make_number (1), Qnil);
+ retry++;
+ goto loop;
+ }
+
+ close(s);
+ s = -1;
+ }
+
+ freeaddrinfo(res);
+ if (s < 0)
+ {
+ if (interrupt_input)
+ request_sigio ();
+
+ errno = xerrno;
+ report_file_error ("connection failed",
+ Fcons (host, Fcons (name, Qnil)));
+ }
+#else /* HAVE_GETADDRINFO */
while (1)
{
#ifdef TRY_AGAIN
@@ -1940,6 +2042,7 @@ Fourth arg SERVICE is name of the servic
report_file_error ("connection failed",
Fcons (host, Fcons (name, Qnil)));
}
+#endif /* HAVE_GETADDRINFO */
immediate_quit = 0;