pkgsrc/net/qbittorrent/patches/patch-src_app_CMakeLists.txt
adam e0119b8bbe qbittorrent: updated to 4.2.2
v4.2.2 changelog:

FEATURE: Allow transfer list text color changes through QSS
FEATURE: Option to show console when external program is run
FEATURE: Rename Country column to "Country / Region"
FEATURE: Change the defaults of some settings
FEATURE: Refactored Transfer List code to allow theming. As a sideffect the row height has more padding.
FEATURE: Allow double-click in preview dialog
FEATURE: Expose stop_tracker_timeout in advanced settings
FEATURE: Add piece_extent_affinity to AdvancedSettings
FEATURE: Reorganize UI theme selection
FEATURE: Show any multiple connections from the same IP in peer list
FEATURE: Add stalled filters to GUI and Web API/UI
FEATURE: Use IP geolocation database by DB-IP instead of MaxMind
FEATURE: Allow to save downloaded metadata as torrent file
FEATURE: Allow single app instance per configuration
PERFORMANCE: Move multiple torrents one by one
BUGFIX: Disable Torrent Queue by default for new users
BUGFIX: Update free disk space label on Category change in Auto Mode
BUGFIX: Save resume data after recheck
BUGFIX: Tracker is errored only if all local endpoints fail
BUGFIX: Change placement of stop tracker timeout setting
BUGFIX: Redesign torrent startup handling
BUGFIX: Show "∞" instead of " -1" in Preferences
BUGFIX: Improve code efficiency for reverse resolution of peers
BUGFIX: Handle HTTP redirection to magnet URI
BUGFIX: Various fixes for portable mode
BUGFIX: Include resume folder path in exception message
BUGFIX: Change placeholder text in torrent list's filter
BUGFIX: Improvements in the embedded tracker to be more spec compliant
BUGFIX: Improve the options tooltips
BUGFIX: Check if file exists in seed mode
BUGFIX: Delegate GUI scaling work to Qt
BUGFIX: Fix crash when renaming torrent contents
BUGFIX: Fix total connected peers count calculation
BUGFIX: Allow other keypresses in LogListWidget
BUGFIX: Disable Auto TMM when not using default savepath from monitored folder
WEBUI: Fix first row renaming in files tab
WEBUI: Use SVG image for WebUI favicon
WEBUI: Inherit text color for filter list elements
WEBUI: Expose WebUI ban counter to users
WEBUI: Expose WebUI ban duration to users
WEBUI: Implement "Secure" flag for session cookie
WEBUI: Remove unused/deprecated option
WEBUI: Prevent excessive sync requests
WEBUI: Fix populating statistics window
WEBUI: Fix matching uncategorized torrents
WEBUI: Always allow whitespace in category names
SEARCH: Bump python version for new installation
SEARCH: Fix missing string
SEARCH: Drop python2 support
WINDOWS: Installer: Option to start qBittorrent on Windows start up
WINDOWS: Installer: Improve Czech translation
WINDOWS: Installer: Update French translation
WINDOWS: Installer: Update German translation
WINDOWS: Installer: Update Japanese translation
WINDOWS: Path length limitation is removed on Windows 10 1607 onwards
2020-03-30 17:17:23 +00:00

41 lines
1.1 KiB
Text

$NetBSD: patch-src_app_CMakeLists.txt,v 1.1 2020/03/30 17:17:23 adam Exp $
Disable app bundle on Darwin.
--- src/app/CMakeLists.txt.orig 2020-03-30 16:49:50.000000000 +0000
+++ src/app/CMakeLists.txt
@@ -27,7 +27,6 @@ set_target_properties(qBittorrent
PROPERTIES
AUTOUIC True
AUTORCC True
- MACOSX_BUNDLE True
)
# translations
@@ -102,7 +101,7 @@ if (NOT DISABLE_WEBUI)
endif()
# we have to include resources into the bundle
-if (APPLE)
+if (FALSE)
set(OSX_RES_SRC_DIR "${qBittorrent_SOURCE_DIR}/dist/mac")
list(APPEND QBT_APP_RESOURCE_SOURCE
"${OSX_RES_SRC_DIR}/qt.conf"
@@ -154,7 +153,7 @@ target_sources(qBittorrent PRIVATE ${QBT
get_target_property(QBT_EXECUTABLE_NAME qBittorrent OUTPUT_NAME)
-if (APPLE)
+if (FALSE)
set(qbt_BUNDLE_NAME ${QBT_EXECUTABLE_NAME})
# substitute @EXECUTABLE@ in dist/mac/Info.plist
@@ -173,7 +172,7 @@ install(TARGETS qBittorrent
BUNDLE DESTINATION .
COMPONENT runtime)
-if (Qt5Widgets_FOUND AND APPLE)
+if (FALSE)
find_package(Qt5Svg REQUIRED)
include(bundle)
endif (Qt5Widgets_FOUND AND APPLE)