While here: - sprinkle stdlib.h widely to avoid undefined behavior calling malloc - fix randomizer setup (was calling srand() and then using random()) - avoid installing a csh script, since we were replacing the entire contents of the file anyhow - add missing libXt and libX11 bl3.mk - add patch comments PKGREVISION -> 4.
14 lines
371 B
Text
14 lines
371 B
Text
$NetBSD: patch-simbreak_c,v 1.1 2012/06/16 04:00:54 dholland Exp $
|
|
|
|
Use standard headers.
|
|
|
|
--- simbreak.c~ 1993-07-14 11:02:09.000000000 +0000
|
|
+++ simbreak.c
|
|
@@ -10,6 +10,7 @@
|
|
** DATUM : 14.03.93
|
|
**
|
|
*************************************************************************/
|
|
+#include <stdlib.h>
|
|
#include "simbreak.h"
|
|
#include "sim.h"
|
|
#include "celltype.h"
|