pkgsrc/misc/openoffice/patches/patch-dh
mrauch 198760d74a Change the bison patches to the version that was agreed on in the
OpenOffice.org project. This also fixes compilation problems with
bison-1.34.
2002-03-29 21:00:10 +00:00

35 lines
1 KiB
Text

$NetBSD: patch-dh,v 1.2 2002/03/29 21:00:11 mrauch Exp $
--- ../connectivity/source/parse/makefile.mk.orig Fri Aug 10 13:09:05 2001
+++ ../connectivity/source/parse/makefile.mk
@@ -67,12 +67,14 @@
# --- Settings -----------------------------------------------------
-.INCLUDE : svpre.mk
.INCLUDE : settings.mk
-.INCLUDE : sv.mk
# --- Files --------------------------------------------------------
+YACCTARGET= $(MISC)$/sqlbison.cxx
+YACCFILES= sqlbison.y
+YACCFLAGS=-v -d -l -pSQLyy -bsql -o
+
SLOFILES = \
$(SLO)$/sqlNoException.obj \
$(SLO)$/sqlbison.obj \
@@ -94,13 +96,3 @@
$(MISC)$/sqlflex.cxx: sqlflex.l
+flex -i -8 -PSQLyy -L -o$(MISC)$/sqlflex.cxx sqlflex.l
-$(MISC)$/sqlbison.cxx: sqlbison.y
- +bison -v -d -pSQLyy -l -bsql -o$(MISC)$/sqlbison.cxx sqlbison.y
- -$(MKDIR) $(OUT)$/inc$/connectivity
- +$(COPY) $(MISC)$/sqlbison.cxx.h $(OUT)$/inc$/connectivity$/sqlbison.hxx
-
-$(SLO)$/sqlbison.obj : $(MISC)$/sqlbison.cxx
-
-$(SLO)$/sqlflex.obj : $(MISC)$/sqlflex.cxx
-
-sqliterator.cxx: $(MISC)$/sqlbison.cxx