a6e120373a
This fixes a number of security problems (integer overflows resulting in heap-based buffer overflow, CVE-2007-4619). Other changes: -speedup -some new options -bugfixes -added support for all RIFF/AIFF metadata Thanks to Chavdar Ivanov for providing a patch.
16 lines
600 B
Text
16 lines
600 B
Text
$NetBSD: patch-ag,v 1.4 2007/11/21 12:47:05 drochner Exp $
|
|
|
|
--- src/libFLAC/Makefile.am.orig 2007-09-14 23:06:17.000000000 +0200
|
|
+++ src/libFLAC/Makefile.am
|
|
@@ -94,9 +94,10 @@ extra_ogg_sources = \
|
|
ogg_encoder_aspect.c \
|
|
ogg_helper.c \
|
|
ogg_mapping.c
|
|
+extra_ogg_libs = -logg
|
|
endif
|
|
# see 'http://www.gnu.org/software/libtool/manual.html#Libtool-versioning' for numbering convention
|
|
-libFLAC_la_LDFLAGS = -version-info 10:0:2 -lm $(LOCAL_EXTRA_LDFLAGS)
|
|
+libFLAC_la_LDFLAGS = -version-info 10:0:2 -lm $(LOCAL_EXTRA_LDFLAGS) $(extra_ogg_libs)
|
|
libFLAC_la_SOURCES = \
|
|
bitmath.c \
|
|
bitreader.c \
|