pkgsrc/devel/py-cffi/patches/patch-testing_cffi1_test__verify1.py
adam 654ef4cede py-cffi: updated to 1.11.5
v1.11.5

* Issue 357_: fix ffi.emit_python_code() which generated a buggy
  Python file if you are using a struct with an anonymous union
  field or vice-versa.

* Windows: ffi.dlopen() should now handle unicode filenames.

* ABI mode: implemented ffi.dlclose() for the in-line case (it used
  to be present only in the out-of-line case).

* Fixed a corner case for setup.py install --record=xx --root=yy
  with an out-of-line ABI module.  Also fixed Issue 345_.

* More hacks on Windows for running CFFI's own setup.py.

* Issue 358_: in embedding, to protect against (the rare case of)
  Python initialization from several threads in parallel, we have to use
  a spin-lock.  On CPython 3 it is worse because it might spin-lock for
  a long time (execution of Py_InitializeEx()).  Sadly, recent
  changes to CPython make that solution needed on CPython 2 too.

* CPython 3 on Windows: we no longer compile with Py_LIMITED_API
  by default because such modules cannot be used with virtualenv.
  Issue 350_ mentions a workaround if you still want that and are not
  concerned about virtualenv: pass a define_macros=[("Py_LIMITED_API",
  None)] to the ffibuilder.set_source() call.
2018-03-01 07:59:54 +00:00

15 lines
510 B
Python

$NetBSD: patch-testing_cffi1_test__verify1.py,v 1.2 2018/03/01 07:59:54 adam Exp $
Add NetBSD support.
--- testing/cffi1/test_verify1.py.orig 2017-07-03 17:44:21.313824096 +0000
+++ testing/cffi1/test_verify1.py
@@ -1767,7 +1767,7 @@ def test_callback_indirection():
#include <malloc.h>
#define alloca _alloca
#else
- # ifdef __FreeBSD__
+ # if defined(__FreeBSD__) || defined(__NetBSD__)
# include <stdlib.h>
# else
# include <alloca.h>