pkgsrc/chat/ircd-hybrid/patches/patch-ab
adrianp 13c39fa83a Update to 7.2.2
> -- ircd-hybrid-7.2.2 RELNOTES
> o) Added channel::disable_fake_channels config directive
> o) Fixed broken FORCEJOIN  (contrib)
> o) Added missing documentation for connect::vhost
> o) Fixed problem with G-Line voting
> o) Fixed "STATS ?" so it doesn't report negative traffic statistics
> o) Fixed core in m_mkpasswd.c  (contrib)
> o) Reduced memory usage for channel members
> o) Added general::stats_e_disabled which simply disables "STATS e"
>    for other operators and administrators
> o) Ignore signal SIGXFSZ to prevent the daemon from dying on missconfigured
>    file size limits
> o) Slight optimizations to the block allocator
> o) Fixed harmless bug that could result in incorrect bytes sent statistics
>    in "STATS t"
> o) "STATS y|Y" now shows whether a class is active or disabled
> o) Added ircd-brazilian_pt.lang language file
> o) Misc. ACCEPT fixes. E.g. don't remove an accept record if a client is
>    changing between equivalent nicknames like 'nick' and 'NiCk'.
> o) Minor resolv.conf parser fixes.  Added missing support for ';' comments
> o) Fixed core on MODRESTART
2006-08-11 16:53:39 +00:00

30 lines
914 B
Text

$NetBSD: patch-ab,v 1.4 2006/08/11 16:53:39 adrianp Exp $
--- modules/Makefile.in.orig 2006-07-17 07:31:35.000000000 +0100
+++ modules/Makefile.in
@@ -24,7 +24,7 @@ IRCDLIBS = @LIBS@ $(SSL_LIBS)
prefix = $(DESTDIR)@prefix@
datarootdir = $(DESTDIR)@datarootdir@
# Change this later! -- adrian
-moduledir = ${prefix}/modules
+moduledir = ${prefix}/lib/ircd-hybrid/modules
automoduledir = ${moduledir}/autoload
INCLUDES = -I../include -I../lib/pcre $(SSL_INCLUDES)
@@ -135,16 +135,6 @@ libmodules.a: $(S_OBJS)
install-mkdirs:
mkdir -p $(prefix)
-
- -@if test -d $(moduledir)-old; then \
- echo "${RM} -rf $(moduledir)-old"; \
- ${RM} -rf $(moduledir)-old; \
- fi
- -@if test -d $(moduledir); then \
- echo "${MV} $(moduledir) $(moduledir)-old"; \
- ${MV} $(moduledir) $(moduledir)-old; \
- fi
-
mkdir -p $(moduledir) $(automoduledir)
install: install_@MOD_TARGET@