pkgsrc/emulators/vice/patches/patch-ae
kristerw 0d4d32992f Update vice to 1.12.
Changes since 1.11 include:
** General changes
- Added -autoload switch which acts like -autostart but without
  actually starting the program.
- It is possible to use the printer emulation without switching off
  true drive emulation now.

** C64 changes
- Mouse emulation should work again.
- Improved trap emulation compatibility.

** C128 changes
- Fixed some VDC crashs.
- Added support for national firmware and keyboard mappings.
- Implemented fast IEC bus.

** PLUS4 changes
- New emulator.  Currently it contains many bugs and several features
  are missing.  Do not send any bug reports for now.

** VIC-II
- Fixed some raster interrupt emulation bugs.
- Some minor NTSC fixes.
- Reset should properly reset the VIC-II now.

** SID changes
- The ReSID state is saved in snapshots now.

** Drive changes
- Improved GCR sync detection.
- Added some more jobcodes to the 1581 emulation.
- RAM mirrors are properly emulated now.
2003-06-23 19:05:09 +00:00

21 lines
681 B
Text

$NetBSD: patch-ae,v 1.5 2003/06/23 19:05:11 kristerw Exp $
--- src/Makefile.in.orig Mon Jun 23 20:03:19 2003
+++ src/Makefile.in Mon Jun 23 20:04:28 2003
@@ -18,7 +18,7 @@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
+pkglibdir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
top_builddir = ..
@@ -220,7 +220,7 @@
# We have to override the automake default, because we need to use
# $(CXX) instead of $(CC) when compiling with reSID.
-LINK = @LINKCC@ $(CFLAGS) $(INCLUDES) $(CPPFLAGS) -o $@
+LINK = @LINKCC@ $(CFLAGS) $(INCLUDES) $(CPPFLAGS) $(LDFLAGS) -o $@
SUBDIRS = \
@RESID_DIR@ \