f9e1049018
Mozilla Firefox is a free, open-source and cross-platform web browser for Windows, Linux, MacOS X and many other operating systems. It is fast and easy to use, and offers many advantages over other web browsers, such as tabbed browsing and the ability to block pop-up windows. Firefox also offers excellent bookmark and history management, and it can be extended by developers using industry standards such as XML, CSS, JavaScript, C++, etc. Many extensions are available.
19 lines
864 B
Makefile
19 lines
864 B
Makefile
$NetBSD: patch-config_baseconfig.mk,v 1.1 2014/11/03 12:18:32 ryoon Exp $
|
|
|
|
--- config/baseconfig.mk.orig 2014-04-18 02:02:39.000000000 +0000
|
|
+++ config/baseconfig.mk
|
|
@@ -2,10 +2,10 @@
|
|
# directly in python/mozbuild/mozbuild/base.py for gmake validation.
|
|
# We thus use INCLUDED_AUTOCONF_MK to enable/disable some parts depending
|
|
# whether a normal build is happening or whether the check is running.
|
|
-includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
|
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
|
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
|
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
|
+includedir := $(includedir)/${MOZILLA_PKG_NAME}
|
|
+idldir = $(datadir)/idl/${MOZILLA_PKG_NAME}
|
|
+installdir = $(libdir)/${MOZILLA_PKG_NAME}
|
|
+sdkdir = $(libdir)/${MOZILLA_PKG_NAME}
|
|
ifndef TOP_DIST
|
|
TOP_DIST = dist
|
|
endif
|