* Fix compile bug with some compilers on 64 bit. Changes 1.16.33: * Build: Fix prototype/definition mismatch in libwww.cpp with some compilers (e.g. Solaris). * Build: Fix linking of xml-rpc-api2cpp with some linkers (e.g. Solaris). Changes 1.16.32: * Windows Abyss server: properly handle wait for connection. Changes 1.16.31: * CGI XML-RPC server accepts (ignores) parameters after "text/xml" in Content-type header from client.
13 lines
515 B
Text
13 lines
515 B
Text
$NetBSD: patch-ai,v 1.2 2011/04/06 07:45:48 adam Exp $
|
|
|
|
--- tools/xmlrpc/Makefile.orig 2011-03-25 16:58:35.000000000 +0000
|
|
+++ tools/xmlrpc/Makefile
|
|
@@ -45,7 +45,7 @@ LIBS = $(LIBXMLRPC_CLIENT) $(LIBXMLRPC)
|
|
XMLRPC_OBJS = xmlrpc.o $(DUMPVALUE)
|
|
|
|
xmlrpc: $(XMLRPC_OBJS) $(LIBS) $(UTILS)
|
|
- $(CCLD) -o $@ $(LDFLAGS) $(XMLRPC_OBJS) $(UTILS) $(CLIENT_LDLIBS)
|
|
+ libtool --mode=link $(CCLD) -o $@ $(LDFLAGS) $(XMLRPC_OBJS) $(UTILS) $(CLIENT_LDLIBS)
|
|
|
|
%.o:%.c $(BLDDIR)/include/xmlrpc-c/config.h
|
|
$(CC) -c $(CFLAGS) $<
|